Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Firefox 7 on Ubuntu 11.10. I am not definitely sure that this problem began since upgrading Ubuntu from 11.04, but that would be my guess.

The problem is fairly simple. Firefox freezes at random times, and when it does, it freezes the whole desktop with it.

I have tried removing every single plug in I have, and the problem persisted. I tried installing them back in one by one to see if any was more problematic than the rest, but no plug in emerged as a clear candidate.

I have tried to discern a pattern. I thought the most likely culprit would be video, like when on YouTube, but that isn't it. Sometimes it happens when I haven't even gone to a web page yet, and I just click to open the bookmarks drop down from the menu.

I would try running firefox -debug from the command line, but the problem is once Firefox freezes, the desktop becomes completely inaccessible. I can still move the mouse, but I can't click on anything on the screen. I can't alt-tab between applications. All I can do is hit ctrl+alt+backspace and then log out.

Any help to diagnose this problem would be much appreciated. I don't mind using Chrome and Chromium (which are stable as rocks on my system), but I have some plug ins on Firefox I can't live without.

share|improve this question

migrated from Nov 2 '11 at 17:15

This question came from our site for professional and enthusiast programmers.

Hey, has someone a different solution? I don't like chrome due to lack of master password and tried a lot things including the VACUUM without much success. Via VACCUUM it got only a bit better but now it freezes several seconds especially on javascript intensive pages like twitter. – Karussell Dec 3 '11 at 21:06
btw I have ubuntu 10.4 – Karussell Dec 3 '11 at 21:07
up vote 1 down vote accepted

This is probably caused by Sqlite3 vacuuming delay. It's a cross-platform issue for recent Firefox versions.

share|improve this answer
Thank you for the suggestion. I am experimenting with the SQLite3 VACUUM solution offered here:… . Is there a command that I can use in Ubuntu that will allow me to run the SQLite Vacuum command on all SQLite files at once? places.sqlite is probably the main culprit, but I'd like to vacuum all of them anyway. I can't figure out how to do that in one command line, so I can only go one by one, like this: sqlite3 places.sqlite VACUUM – Questioner Nov 3 '11 at 8:45
Yes, you can use find command: find . -name '*.sqlite' -exec sqlite3 {} VACUUM \; – Mikhail Kupchik Nov 3 '11 at 16:19
Thank you. I have "vacuumed" all the sqlite files in my Firefox profile directory, and now I'm going to run Firefox for a day or so and see if it is any more stable. I'll report back here when and if it seems I have a clear result. – Questioner Nov 3 '11 at 20:26
After running Firefox for a while, it seems that this solution has worked. I did experience one freeze, but unlike before, after waiting a few seconds, I got control back again. I assume I'll have to run this vacuum command every now and again until they fix this bug. Thank you for the help! – Questioner Nov 5 '11 at 2:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .