Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Writes to my WD Caviar Green 2TB hard drive are exceedingly slow. When dpkg is setting up packages atop reports speeds of between 0.5 and 1 MB/s. AHCI is enabled in my bios. I bought the drive new. What could be wrong? What can I do to troubleshoot?

This is on Ubuntu 11.10. 3 partitions are 1%, 5% and 50% used respectively.

edit: I had originally misidentified the drive as my SSD drive but later found my mistake when running a benchmark to troubleshoot.

edit2: File system is btrfs.

share|improve this question
    
How have you isolated this as being a disk speed issue? dpkg does various things when setting up a package, only a subset is writing to the disk. It could be slow decompressing for example. –  Paul Nov 2 '11 at 23:46
    
I was using the output of atop which indicated 100% "busy" and had DSK=100% for dpkg. –  user64996 Nov 3 '11 at 0:30
    
DSK=100% for dpkg just means dpkg is accounting for 100% of the system's disk usage. –  David Schwartz Nov 3 '11 at 0:32
    
Yes, see my comment to your answer where I explain that the system usage indicated 100% "busy". –  user64996 Nov 3 '11 at 0:43

2 Answers 2

up vote 1 down vote accepted

It turns out my disk is an "Advanced Format" drive with 4K sectors. The problem is that Ubuntu's installer did not partition them on 8-sector boundaries which results in the poor speed that I am seeing.

Although I haven't done it yet the solution is to repartition using 8-sector boundaries (destructive) or to try to use the "WD Align" utility which is supposedly non-destructive.

share|improve this answer

I give you the same answer as last time, the drive is operating at normal speed, it's just not receiving a whole lot of writes.

If you are still establishing that the drive is the bottleneck because atop is reporting 100%, you are likely misreading the output of atop. (For example, the system disk activity will always total 100%.)

For example, this is from a mostly idle system:

  PID                RDDSK                 WRDSK                WCANCL                 DSK                CMD        1/1
  349                   0K                   40K                    0K                 83%                jbd2/sdb1-8
 1394                   4K                    4K                    0K                 17%                squid

Notice the disk activity totals 100%.

share|improve this answer
    
I was reading the system information (the section at the very top in an invocation of "sudo atop") and not the per-process information to establish that disk utilization was 100%. I used the per-process information only to establish what application was causing it. –  user64996 Nov 3 '11 at 0:32
    
What was the % busy for the drive? –  David Schwartz Nov 3 '11 at 0:33
    
BUSY for the drive was 100% (or about that) –  user64996 Nov 3 '11 at 0:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.