Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was trying to get passenger to work on my home computer and ran into this problem.

I get this error when I try to start Apache.

(13)Permission denied: make_sock: could not bind to address [::]:80
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:80

I get Syntax OK when I test Apache.

this is where I set port 80 in my Apache config file.

 52 NameVirtualHost *:80

 53 Listen 80

Not sure what I am doing wrong.

share|improve this question
up vote 4 down vote accepted

Does this help?

  1. Go to my System Preferences.app and open “Sharing” pane. Disabling the Web-Sharing service.

    enter image description here

  2. Launch Terminal.app and stopping httpd (apache) with the following command:

    sudo apachectl -k stop
    
  3. Going into the Activity Monitor.app and searching for “httpd”. Select both processes and click on “Stop”.

    enter image description here

  4. Shutdown and start my Mac (do a proper shutdown, not restart!)

  5. When Mac was back up running: go in to Terminal.app and execute:

    sudo apachectl -k start
    
share|improve this answer

The problem will be that you didn't start Apache as root - by default on any unix based operating system only root can bind a process to a port below 1024.

Your choices are to either use a port higher than 1023 and remember to specify it when you connect, or to ensure that you start Apache as root. Unfortunately not being a Mac user I can't provide details of how to do the second.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .