Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought a Samsung rf511 notebook. While I find it an excellent buy, I have one problem with it: many of the Samsung apps that come preinstalled nag me each time I boot up the computer and login; asking for administrator rights.

The culprits are, for example, the apps Battery Life Extender, Easy Speedup Manager, Wifi Manager, Smart Restarter, etc.

This happens when I open my common user accounts, but not when I login as administrator. This also seems to happen just the first time I login with each account. Note that logging in as one user, allowing all the apps, then logging out to another user still results in double the pleasure of inputting the admin password (up to 4 times each).

How can I make them stop asking for permission each time I login, short of uninstalling them?

EDIT I tried the instructions on the links provided by @techie007, but the instructions didn't work. More specifically, the relevant scheduler task already exists, and is set to run with the highest privileges. I've tried both making it run as admin and unchecking that option, with the same results. I'm loathe to disable UAC completely.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

I solved the problem by changing the account under which the nagging applications are set to run in the scheduler.

  1. Click Start, right click on Computer and choose “Manage”.
  2. Click “Task Scheduler” on the left panel.
  3. Expand "Task Scheduler" by clicking on the triangle.
  4. Click on the "Task Scheduler Library".
  5. In the window that pops up on the right, double click on the programme that causes the problem.
  6. Click on "Select user and group" in the properties window that appear.
  7. In the field object name, type in an administrator name.
  8. Click "Check name".
  9. Check the result and click OK.
  10. Click OK in the properties window.
  11. Repeat 5-11 for every programme that causes this problem.
share|improve this answer
add comment

By the sound of it, I'm going to assume you're using Windows (you should aim to include useful information like that in future questions, as not everyone runs Windows ;) ).

It also sounds like the applications are user-specific, yet need Administrator access (at least the first time they run for each user), probably to write configurations or alike, and you are being "nagged" by Windows' UAC.

If you want to temporarily disable these programs form startup, without uninstalling them, then you can use MSConfig or another startup program manager (see: What is the best software for managing startup applications?).

If you don't care about security then you also have the option is disable UAC (see: Disabling UAC on Windows 7?).

To keep your security, yet not have UAC for these programs then, with some work, you can also disable UAC per-program (see: Selectively disabling UAC for specific programs on Windows 7)

share|improve this answer
    
Absolutely right, I'm running Win7. I retagged. –  Adriano Varoli Piazza Nov 3 '11 at 18:16
    
I tried the instructions on your last link, but the instructions didn't work. More specifically, the relevant scheduler task already exists, and is set to run with the highest privileges. I'm loathe to disable UAC completely. –  Adriano Varoli Piazza Nov 10 '11 at 13:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.