Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My MacBook Air connects to my company network, but will not connect to the internet through the network. It shows this message:

Wi-fi has the self-assigned IP address 169.254.20.235 and will not be able to cnnnect to the Internet.

In Advanced Settings, I've tried to renew the DHPC lease to no avail. I am not in position to shut down the company router, so I've got to work through the Mac. It works fine at my home network.

share|improve this question
3  
Then it's most probably an issue with your company's router if it fails to lease an address to your Mac. –  slhck Nov 3 '11 at 20:23
2  
Contact the company IT department for assistance. They may need to approve the MAC address As @slhck notes, the cause is at the company level. –  Dave M Nov 3 '11 at 20:26
    
Some companies require a cert before authorizing access to the wireless network. –  JW8 Nov 3 '11 at 20:59
add comment

2 Answers

The most common things I have seen for problems like this are:

  1. You have everything correct, but the router has no more DHCP licenses to hand out. You may need to have IT allow more DHCP connections.

  2. You have the SSID correct, but something is wrong with the WPA key. You'll get a message about connecting to the SSID you expect, but because the key is wrong, it can't authenticate and get an address.

share|improve this answer
add comment

As a last resort you can reset all of the network settings and start fresh. Go to /Library/Preferences and delete the folder called SystemConfiguration and then restart your computer.

This should reset all network settings and you will have to rejoin any wireless networks you were previously on. If it is an issue on your Mac side then this should take care of it. Although you won't have to reenter your passwords because those are stored in the Keychain.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.