Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to get firestarter running on Ubuntu 11.10 and I am getting an error:

Failed to start Firewall
The device eth1 is not ready.
Please check your network device settings and make sure your Internet connection is active

I have edited my /etc/default/isc-dchp-server to show INTERFACES="eht1"

I am not sure where to go from here. Do i need to edit /etc/network/interfaces?

Also I have both /etc/network and /etc/networks What is the difference?

ifconfig -a results:

eth0      Link encap:Ethernet  HWaddr xx:xxxxxxxxxxxxx  
      inet6 addr: xxxxxxxxxxxxxxxxx/xx Scope:Link
      RX packets:9646 errors:0 dropped:0 overruns:0 frame:0
      TX packets:3194 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:1739614 (1.7 MB)  TX bytes:505743 (505.7 KB)
      Interrupt:18 Base address:0xa000 

eth1      Link encap:Ethernet  HWaddr 50:xxxxxxxxxxxxxxxx  
      inet addr:  Bcast:  Mask:
      inet6 addr: fe80::52e5:49ff:fe39:d40f/64 Scope:Link
      RX packets:110 errors:0 dropped:0 overruns:0 frame:0
      TX packets:43 errors:0 dropped:0 overruns:0 carrier:1
      collisions:0 txqueuelen:1000 
      RX bytes:26196 (26.1 KB)  TX bytes:6475 (6.4 KB)

lo        Link encap:Local Loopback  
      inet addr:  Mask:
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:16436  Metric:1
      RX packets:16 errors:0 dropped:0 overruns:0 frame:0
      TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:1184 (1.1 KB)  TX bytes:1184 (1.1 KB)
share|improve this question
Please post an /sbin/ifconfig -a – Paul Nov 4 '11 at 3:08
How many NICs (network cards) you got? If you have only one you usually need to use eth0 and not eth1. Also your wrote INTERFACES="eht1". I hope this is just a typo here... – m0skit0 Nov 4 '11 at 8:35
@m0skit0 - I have 2 NICs. eth0 is external, and eth1 is internal. DHCP needs to hand out ips on eth1 (internal) so I configured it to listen on eht1 in the isc-dhcp-server file. – Siriss Nov 4 '11 at 13:17
@Paul - I will post my ifconfig -a results when I get home this afternoon. Thank you for the help! – Siriss Nov 4 '11 at 13:18
ifconfig -a results have been appended to original question. Thank you again! – Siriss Nov 4 '11 at 20:31
up vote 1 down vote accepted

This happened to me when I had a bridge from eth0 to virbr0 (for kvm/qemu). So if anyone get a similar problem try disabling the bridge (in /etc/network/interfaces), restart network and try again. After adding rules you can re-enable the bridge.

Or just do not use Firestarter. It's a dead application and it seems like the problem is a bug in Firestarter.

For other GUI for firewall see:

share|improve this answer
I ended up not using Firestarter and just learned iptables command line. Works perfectly, of course. Thanks for the answer! – Siriss Jun 25 '14 at 15:32

You can search string "Failed to start Firewall" in scripts, and find exactly was is attented.
In a lot of scripts under Linux, an error message can't be really relevant.
You need to find exactly which commmand / which line do this message: it's a good way to find what is attended. You need to see inside the system.
(answer edited under the pressure of an administrator here ;) )

share|improve this answer
Your answer is a bit confusing right now. Could you edit it to explain a bit more about how this would work and what it would do to help? – nhinkle Nov 5 '11 at 0:19
thanks for the answer boup, but I don't quite get what you mean? Could you please elaborate? – Siriss Nov 6 '11 at 19:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.