Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 2008R2 Server named SERV1 connected to a Unix machine UNI1.

I can ping but I can't telnet.

I have installed the telnet client on server R2. I disabled the Windows Firewall on R2. Do I need to check any services running in services.msc on R2 machine?

share|improve this question
    
Just a comment.... To telnet works, you will need to have a TCP port on LISTENING state on server's side. You can check it on the server using netstat -a –  Diogo Nov 4 '11 at 13:48
    
SERV1 has 2 IP-adresses 172.26.1.40 and 172.26.1.42? UNI1 172.28.150.10 is in another network? And then FUN-SERV1 and DRIVER-SERV1 are again in a third network? Can you show the ifconfig (or ipconfig) for each interface and the routing table on each host? Now from where to where do you want to telnet? –  ott-- Nov 4 '11 at 14:05
1  
This is barely comprehensible, but appears to be an exact duplicate of the question that this questioner asked last week. Xe is still trying to telnet from that Windows machine to the Unix machine. –  JdeBP Nov 4 '11 at 14:12
    
i believe telnet is required from DRIVER-SERV1 to 172.26.1.40 The switch is unmanaged and it is in DR lan –  steveaston Nov 4 '11 at 14:44
    
Can you please just post one question to one problem you're having? Your question here contains even less information than the one before? It would be much better if you could just have one question with all the details. –  slhck Nov 5 '11 at 10:24

2 Answers 2

up vote 5 down vote accepted

To telnet from a Windows computer to a Unix computer you need to ensure that

  • Windows has telnet client installed (it is not installed in latest Windows)
  • Windows firewall is not blocking outgoing Telnet (very unlikely)
  • Windows can resolve server's name (e.g. through DNS or local hosts file)
  • Unix server has Telnet service enabled (increasingly being disable to encourage SSH use)
  • No intermdiate firewalls are blocking Telnet (unlikely if both computers are in same subnet)
  • You have valid Unix login credentials (user name and password)

Since you didn't post an actual error message but just said you "can't do telnet" - we can only guess at the problem.

To check if the Telnet service is runnning, log on at the Unix server console and use this command:

netstat -a | grep "telnet.*LISTEN"

The output should be this

tcp        0      0  *.telnet               *.*                    LISTEN

Note: If you have problems, update your question with the actual command and error messages by using cut & paste (then edit only if needed to change confidential details)


Update:

Redhat / Fedora

Use these commands

chkconfig telnet on
chkconfig --list | grep telnet

The output from the second command should be

   telnet: on

Ubuntu

sudo apt-get install telnetd
sudo /etc/init.d/inetd restart

Once installed, from the GUI, select Administration, Services and enable Telnet

Distros using Xinetd

You need a file named /etc/xinetd.d/telnet with contents something like this

# default: on
# description: The telnet server serves telnet sessions; it uses \
#       unencrypted username/password pairs for authentication.
service telnet
{
        flags           = REUSE
        socket_type     = stream
        wait            = no
        user            = root
        server          = /usr/sbin/in.telnetd
        log_on_failure  += USERID
        disable         = no
}

Warning!

You shouldn't be doing this unless you are familiar with Linux, with Linux commands, with editors such as vi and have good backups and are prepared to reinstall if it all goes horribly wrong. If other people rely on this server, you should employ a systems administrator who is familiar with the particular Linux distribution you are using.

share|improve this answer
    
@steveaston, Yes but omit the ">" (which is a prompt character displayed by the server, not part of the command). If you get an empty answer (just a new command prompt) it means the Telnet service is not enabled. If it isn't, update your Question with output of uname -a command. –  RedGrittyBrick Nov 4 '11 at 14:16
    
@steveaston: It depends on the version of Unix - which is why I earlier asked for the output of uname -a –  RedGrittyBrick Nov 4 '11 at 14:42
    
Now the issue is telnet cannot be open from cmd screen of SERV1 to UNI1 (Linux). It seems telnet service is not available on J-Proc (Linux). How to resolve this issue, ? –  steveaston Nov 4 '11 at 15:28
    
@steveaston: How to resolve this issue? - I think the only way is for you to provide your helpers with the specific information they asked for. Linux! Which distro? Which release? See this article –  RedGrittyBrick Nov 4 '11 at 15:38
    
@steveaston: The command starts after the # –  RedGrittyBrick Nov 4 '11 at 16:16

what are the steps … [I] need to do?

  • Give up on Telnet.
  • Download Putty,
  • install it on your Windows 2008 server and
  • use Putty to connect to UNI1 using the SSH protocol (port 22).
share|improve this answer
    
SSH is much more secure and viable than telnet. –  Broam Nov 4 '11 at 16:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.