Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Fedora 16.

I shut down NetworkManager and wpa_supplicant (using service commands), but when I try:

sudo service avahi-daemon stop

or

sudo kill pid

it appears again instantly! How can I figure which process is still using avahi?

share|improve this question
1  
If you have time, please upvote and/or pick an answer. Thanks! – phw Apr 10 '12 at 20:50

OP posted this also in the Fedora Forums here.

The solution is to disable the service altogether:

systemctl disable avahi-daemon.service

That worked for me.

share|improve this answer

The command

systemctl stop avahi-daemon.service 

should work.

share|improve this answer
    
I tried that but it didn't work the only way was to disable it and restart – cap10ibraim Nov 4 '11 at 20:34
2  
@Niels could you edit your answer to include a bit more info about how your solution works? – nhinkle Nov 4 '11 at 20:40
    
what gives the command systemctl status avahi-daemon.service ? – Niels Nov 5 '11 at 10:08

If someone accidentally come across this - in my opinion the problem is that avahi-daemon.socket is bringing the process up again after you kill it (or try to stop it). The idea of sockets is that on the general the service does not need to be started when the system is loaded, but just when someone really needs it. The socket only monitors if someone needs the service and spawns it. I would try stopping the socket first (systemctl stop avahi-daemon.socket) and see if after that I can stop the service. See this for more information about sockets.

Another thing that might happen is that systemd can respawn a crashed service (or service that got killed). In this case though, systemctl stop avahi-daemon.service should work.

share|improve this answer
    
It seems, this also is accurate for disabling avahi-daemon.service - you have to disable also avahi-daemon.socket to prevent avahi waking up. – JustAMartin Jun 14 at 20:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .