Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I developed a website with a favicon and now every time I access localhost (for my other projects), I get that same favicon showing up. I'm on OSX, using Chrome. I tried clearing the cache; it flashed to the default unknown favicon first, then immediately grabbed the website one (that I don't want). Anyone know where to find that favicon so I can remove it? None of my other browsers have this problem (Firefox, Safari).

share|improve this question
    
Are you using an actual release version of Chrome or some buggy testing alpha/beta/canary build? – Daniel Beck Nov 4 '11 at 16:33
    
Cannot reproduce. Visited http://localhost after setting up /favicon.ico on the site, it was displayed. Deleted favicon file, cleared cache and restarted Chrome: It's gone. – Daniel Beck Nov 4 '11 at 16:36
1  
I am using an actual release of Chrome. Also- I deleted the entire project directory where that favicon is stored, cleared my cache in Chrome and restarted the browser and it still is showing up on localhost. Any other advice? – jfedick Nov 4 '11 at 17:32
up vote 2 down vote accepted

To fix this, I went into Preferences, Under the Hood, Clear Browsing Data, and selected all the options with "from the beginning of time" as the date reference. I was hoping to not have to do this and lose all my browsing history/data, but it worked.

share|improve this answer

You can of course always make an empty PNG file and set it as the favicon in an index.html page so the cache is overwritten:

<html><head><link rel='icon' type='image/png' href='favicon.png' /></head></html>

The default icon is still not there :( but it's a way to avoid deleting all your history.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .