Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A while ago I started using Chrome and no longer Firefox, however I found out something weird which maybe force me to return to Firefox if I can not fix this. I am coding a homepage and the output was in Chrome ugly, in Firefox not. I thought "ok this is maybe due to bad code"... however I found out that the same problems occurs on different sites like Facebook too. The font is not smoothed and it is not nice to read. Here is an example, although I have censored nearly everything...

Bad Chrome Rendering

Bad Chrome Rendering

Good Firefox Rendering

Good Firefox Rendering

You may need to open up in a new tab to see the errors in detail. Now I want to know, whether this is just Chrome trolling me or maybe something else.

EDIT I tried it out under Ubuntu on my PC and it works well... seems to be an error on Windows/Chrome on Windows.

share|improve this question
1  
Not a programming question, voting to move to superuser. –  Chris Thornton Nov 3 '11 at 18:09
    
@ChrisThornton: Thought to post in WebApps@Stackexchange, however thought here would be better... –  Christian Ivicevic Nov 3 '11 at 18:10
add comment

migrated from stackoverflow.com Nov 4 '11 at 17:18

This question came from our site for professional and enthusiast programmers.

4 Answers

up vote 2 down vote accepted

This issues wasn't fixed yet as it still persists and is a bug in Chrome - even after installing Windows 8 I still have the same issue, so no solutions of you could me here.

share|improve this answer
add comment

Go to My Computer and click on it using your right mouse button, choose Properties then choose the tab Advanced.

In Performance, click on Settings, then select Visual Effects and scroll down until you find "smooth edges of screen fonts" and check it.

Click OK, accept changes and reboot your computer.

share|improve this answer
add comment

The issue is created because chrome actually cannot render TrueType fonts with correct anti-aliasing. However, chrome still renders SVG files well. If you move the call for your svg file up in your syntax, chrome will download the svg and use it instead of the woff file.

Further reading:

share|improve this answer
add comment

I got the same rumbling here http://www.google.com/support/forum/p/Chrome/thread?tid=2869ded2f0340d1d&hl=en

Try to check for GPU Acceleration on Chrome. Type on the URL bar "about:flags" without the " and look where it says GPU Accelerated Canvas 2D. Try to disable it if enabled. Fonts on some sites appear really jagged when I browsed with the acceleration enabled.

share|improve this answer
    
The Acceleration was disabled by default. Nothing changed... –  Christian Ivicevic Nov 4 '11 at 20:32
    
This is basically a known issue: Chrome sucks at font rendering on Windows. –  nhinkle Jun 10 '12 at 4:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.