Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a website running on IIS7.5 on a Windows 2008 R2 server. I'm attempting to download a file from the site that is 3GB. But the download just stops at 2GB. No error in the log.

What I have done:

Set maxRequestEntityAllowed to 10000000 for the site.
Set maxRequestEntityAllowed to 10000000 for IIS.

Any ideas?

share|improve this question
    
Were you using IE 7 at the time of this question? support.microsoft.com/kb/298618 –  Ek0nomik Jun 17 at 16:26
    
@Ek0nomik -- HAHAHAHA. Nope. –  NitroxDM Jun 17 at 16:56
    
You never accepted an answer or answered your own question. Did you end up resolving the issue? If so, you should add answer. The current answer seems irrelevant as that's for request filtering. –  Ek0nomik Jun 17 at 18:54
    
@Ek0nomik -- It's still an issue. Thus the lack of a accepted answer or an answer provided by me. –  NitroxDM Jun 18 at 17:28

1 Answer 1

I am not entirely sure what maxRequestEntityAllowed does, but, I know maxAllowedContentLength should work, just make sure you add it to the correct place inside your web.config file.

As you said you do not have an existing web.config file create one with the following:

<?xml version="1.0" encoding="utf-8"?>
<configuration>
    <system.web>
        <security>
            <requestFiltering>
                <requestLimits maxAllowedContentLength=”9999999999″ />
            </requestFiltering>
        </security>
    </system.web>
</configuration>
share|improve this answer
    
There isn't a config for this site... so I'll give it a go with a blank config and see what happens. –  NitroxDM Nov 4 '11 at 22:55
    
@NitroxDM How did you do the setting in the site like you said in your question? :/ –  William Hilsum Nov 4 '11 at 23:04
    
iis.net/ConfigReference/system.webServer/asp/limits -- I'm guessing that is just for caching... but it's the closest thing I have found so far. –  NitroxDM Nov 4 '11 at 23:17
    
Doesn't seam to matter where I put it I get an error "the configuration section 'Security' cannot be read because it is missing a section declaration." –  NitroxDM Nov 4 '11 at 23:25
    
@NitroDM, ... Ok, I have updated the question, copy and paste exactly in to a new web.config file, and put it in the same folder as the file. –  William Hilsum Nov 4 '11 at 23:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.