Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just got this error message when trying to play the " Pirates of the Caribbean" DVD on my workstation.

Windows Media Player cannot play this DVD because there is a problem with digital copy protection between your DVD drive, decoder, and video card. Try installing an updated driver for your video card.

The video card software is up to date (according to Device Manager)

How do I fix this issue?

share|improve this question
    
Have you checked with the manufacturer of your video adapter for a newer driver? Are you trying to output to your primary monitor, or another display device (like a TV)? Do other copy protected DVDs work as expected? –  Ƭᴇcʜιᴇ007 Nov 5 '11 at 1:19
    
Which Edition of Windows 7 do you have? If Home Basic or Starter, what DVD codec are you using? –  David Schwartz Nov 5 '11 at 2:42
    
@DavidSchwartz I have Windows 7 Ultimate. How do I find what the DVD codec is? –  Raj More Nov 5 '11 at 10:33
    
@techie007 I have a 3 monitor HDMI setup. One connects to the HDMI output on the mother-board and the other two connect to my Radeon card. I am playing the video on one of the Radeon card outputs with the other two monitors disabled. –  Raj More Nov 5 '11 at 10:35

1 Answer 1

I would just download and install VLC and play the DVD in that.

http://www.videolan.org/vlc/index.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.