Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Apache Web Server correctly installed on my PC, wich has a fixed local IP of 192.168.1.2. If I do localhost, 127.0.0.1 or 192.168.1.2 the Apache show his initial page.

Now I want to access this web server from any place on web. I know my external IP (it's dynamic, but this is not problem now), but when I use "http://myexternalIP" I'm seeing the configuration page of my router and not my Apache web server.

I've done some things to solve this, but to not induce your answers please consider that this is my only question :) As soon I do tests I'll tell more information.

There are any ways to do that?

Hello, some new informations...

Now i have made some Firewall (Windows firewall) rules to allow input traffic (TCP and UDP) on port 8080. My router is forwarding this port. I used this service (http://www.yougetsignal.com/tools/open-ports/) to check my 8080 port and there says "Port 8080 is open on ."

But, accessing the :8080 i get Error on loading page. And now? Some Ideas?

share|improve this question

migrated from serverfault.com Nov 5 '11 at 3:12

This question came from our site for system and network administrators.

    
It is time to learn about port forwarding, amigo. –  Matt Ball Nov 5 '11 at 1:05
    
Yep, it's port forwarding that you need. Also, the fact that anyone in the world can see your router's configuration page is not good. You shouldn't have things configured such that you can access that from the WAN side or your network (or at least not without going to great lengths to secure it) –  Todd Nov 5 '11 at 1:09
    
@MattBall: Yes, I Know :) Now I know everything about Port Forwarding because I lost some days of research on how to do what I want, BUT, unfortunatelly PF is not working as should. On the DSL-2640b, at least on my firmware, the PF is called "Virtual Hosts". There i can set the LAN IP (fixed) where APACHE is installed, External Ports (start and end), protocol (TCP/UDP) and Internal Ports (start and end). After that I reboot the router and access "MyExternalIP"; but ALWAYS the router config page appears. My external IP i get here :canyouseeme.org. So, any Ideas? –  Ðerek Wildstar Nov 5 '11 at 3:01
    
@Todd: I think this, like you, but the true and bizarre default on my firmware DSL-2640b is to allow external access to the config interface of the router, however, always is asked the login and password. This turns whole the thing a little bit more secure. Well, don't worry about it because I' know how to deny external access to the config interface but now I only have on goal: "acess my Apache from any place on Web". –  Ðerek Wildstar Nov 5 '11 at 3:07
    
Well... No one can help me? :( –  Carlos Feitoza Filho Nov 23 '11 at 13:52

2 Answers 2

Not sure about that router in partictular, but you need to open the firewall on it for port 80 and redirect that port to the IP of your server (192.168.1.2). Probably also have to turn off remote administration, or at least configure it to another port.

share|improve this answer
    
Hello @Law, thaks for help. Well, as I said on my comments above, I have done the port forward some times. On my router/firmware this feature is called "Virtual Hosts" and I tried: redirect external port 80 to internal port 80 at 192.168.1.2 –  Ðerek Wildstar Nov 5 '11 at 3:12
    
Hello @Law, thaks for help. Well, as I said on my comments above, I have done the port forward some times. On my router/firmware this feature is called "Virtual Hosts" and I tried: 1. Redirect external port 80 to internal port 80 at 192.168.1.2; 2. Redirect external port 80 to internal port 8080 at 192.168.1.2; 3. Redirect external port 8080 to internal port 80 at 192.168.1.2; 4. Redirect external port 8080 to internal port 8080 at 192.168.1.2; 5. Redirect external port 8081 to internal port 8081 at 192.168.1.2... Etc. But always is the same thing: Admin page or not found. –  Carlos Feitoza Filho Nov 5 '11 at 3:24
    
@Law: About turn off the remote administration feature i saw on many places on the web that this is possible on DSL-2640b, however my Admin UI does not have this option! Looks like my UI is different. I can provide some screenshots later. –  Carlos Feitoza Filho Nov 5 '11 at 16:30
up vote 0 down vote accepted

I'm glad to say that I was able to solve this problem, at last!!

The problem that not even the D-Link support was able to settle in Brazil, it was just a WAN Service configuration called "Bridge PPPoE Frames Between WAN and Local Ports."

Follow the path: ADVANCED SETUP > WAN Service, then click the "Edit" button from the WAN service you want to change, then NEXT then NEXT again and there are some checkboxes on the screen.

One is "Bridge PPPoE Frames Between WAN and Local Ports." Check this checkbox and click "NEXT" 3 times more and finally click the "Save / Apply" button. Finally, just reboot the router.

With this option enabled I can access my web server, located in my home, from the Internet!

What a shame, huh, D-Link Support Brazil?!?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.