Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I would like to listen to music while in safe mode. I have tried to start the audio service manually, but it returns error code 1068.

I would also accept a solution in C or C++ if programming is necessary to do this.

(The easiest way would be to start Windows in normal mode, but I like challenges)

share|improve this question

migrated from stackoverflow.com Nov 5 '11 at 21:57

This question came from our site for professional and enthusiast programmers.

    
Version of Windows you are using? –  suddnely_me Nov 5 '11 at 21:49
7  
Safe mode is not intended for normal use. –  Cat Plus Plus Nov 5 '11 at 21:51
3  
Oh, please don't migrate this to SU. Poor guys. –  Hans Passant Nov 5 '11 at 21:57
3  
Why don't we just solve the problem of why you are running in safe mode to begin with? It should never be necessary to run safe mode other than to fix whatever is preventing normal mode use. –  Paul Nov 5 '11 at 22:46
3  
A radio next to the computer seems to work well. –  LarsTech Nov 6 '11 at 13:47

4 Answers 4

This is how to do it in Windows XP:

  1. Run (⊞Win+R) regedit
  2. Press Ctrl+F
  3. Make sure Keys, Values, and Data are all selected
  4. Type in Sound, video and game controllers
  5. Click [Find Next]
  6. Take note of the branch address in the status bar at the bottom (it will be something like HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E96C-E325-11CE-BFC1-09002BE10318})
  7. Copy the device-driver GUID (the long numeric part between braces) and paste it somewhere like Notepad
  8. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SafeBoot\Network
  9. Create a new key (right-click, select New → Key)
  10. Copy the GUID you saved and paste it into the key name
  11. Edit the (Default) value and type Sound, video and game controllers
  12. Create several new keys (under Network) called AudioEndpointBuilder, MMCSS and Audiosrv
  13. Edit the (Default) values of each of the new keys and type Service
  14. Reboot (you’ll boot into safe-mode)
  15. Open the Services snap-in (⊞Win+Rservices.msc)
  16. Start the Multimedia Class Scheduler, Windows Audio Endpoint Builder, and Windows Audio Service services
share|improve this answer

Use start > run > services.msc

Enable

  • Plug and Play Service

  • Windows Audio Service

enter image description here

share|improve this answer
    
thank you but I have tried to start the audio service but it returns width error code 1068. :( –  user65130 Nov 5 '11 at 22:01
    
has PnP service started? –  Eir Nym Nov 6 '11 at 0:14
  1. Press Windows + R, type devmgmt.msc, press Enter and look for your sound device. (e.g. Realtek High Definition Audio) Double-click it.
  2. Go to the tab 'Details' and click the drop-down list. Select 'Driver key' and copy the text from 'Value'

  3. Copy the text into a word processor (e.g. Notepad)

  4. Replace all lower-case letters with capital letters and remove the \0000.
  5. Open Registry Editor (Windows + R > regedit) and locate HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SafeBoot\Network.

  6. Create a new key (Rightclick > New > Key)

  7. Copy the text from your word processor and paste it into the key name.

  8. Edit the '(Default)' key and type 'Sound, video and game controllers'.

  9. Create a new key called 'AudioEndpointBuilder', 'MMCSS' and 'Audiosrv'
  10. Edit all their '(Default)' keys and type 'Service'.

  11. Restart your computer

  12. Go to Services (Windows + R > services.msc) and start Multimedia Class Scheduler and Windows Audio Endpoint Builder.

  13. Then start Windows Audio Service

share|improve this answer

Found this amazing yet simple working solution to the problem: http://www.techsupportforum.com/forums/f10/sound-in-safe-mode-83906.html#post2250578

Good Day!

- Bukhari

share|improve this answer
    
Welcome to SuperUser. Please provide more details in your answer and summarize the relevant portion from your linked solution. –  Brad Patton Apr 13 '13 at 14:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.