Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a local Apache server running, which is defined through /etc/hosts as "apache". So I often open pages like:

http://apache/website/

Normally, this works fine. However, since I am using a more recent Chrome browser, at odd moments the browser decides that the URL I type is not a URL but actually a search, so it loads my default search engine and tries to find this URL. It often, but not always, shows a link under the address bar that says Did you mean to go to http://apache/website?. That is nice, but very annoying having to click here instead of going there directly. What makes Chrome behave this way? Can I fix this?

share|improve this question

4 Answers 4

You can implicitly do this by creating a new search engine with a URL of http://%s and keyword of null. Then, set this as the default search engine.

Search Engines

share|improve this answer
1  
That's a neat trick. I'll have to try it out! –  afrazier Nov 6 '11 at 1:27
1  
@iglvzx Thanks, but this only works if I always want to open any keyword this way. I really like to keep using Google Search when typing other words, but I just don't want this to happen when I am typing a localhost URL. –  user95156 Dec 28 '11 at 22:02
    
It's no longer possible to set 'null' as keyword as of Chrome v26. –  skolima Apr 8 '13 at 13:20
1  
@skolima It's possible in v27.0 –  svandragt May 14 '13 at 10:03
1  
@svandragt: v27 is now stable and unfortunately this is still disabled. Crap. –  skolima May 22 '13 at 9:58

I got annoyed by this as well. I recently found out what caused it. Try disabling 'Use a web service to help resolve navigation errors'.

share|improve this answer
1  
This does not work if I then add to the URL. e.g. I load local.symphony-2.3 and then add /symphony or /symphony/ to the URL, chrome searches google for that phrase. –  codecowboy Apr 20 '12 at 7:50
    
This works perfectly for me, thanks! –  Nik Jun 18 at 10:44

I had the same problem and i found that typing the / at the end will always treat it as a url instead of keyword.

For example in my case :

local.dev/ben is treated as search

but

local.dev/ben/ its working fine
share|improve this answer
3  
+1: This should be the accepted answer! :) –  Thomas Bratt Aug 2 '13 at 13:38
    
Saying that appending a / at the end will always treat it as a url instead of a keyword does not always hold true, for example scoped link local addresses will trigger a search even if a / is present: https://[fe80::1%eth0]/ –  Tiernan Sep 26 '13 at 8:59

If you know the port you're using, you can specify it by hand like

url:80/index.html

instead of

url/index.html

In the first case, it won't be treated as a search request

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.