Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have an old laptop here with WinXPSP3, and several other laptops, some of which are XPSP3 as well. All of them are able to connect to our non-SSID-broadcasting router, except this one. We've added the SSID the exact same way as on the others, but no matter how many times I delete and re-add it, or reboot, it doesn't seem to ever show up on the list when I refresh it. I set the option in the specific network itself saying connection whether it's broadcast or not.

Also, it connects to other (random) networks it can see, just fine.

Any ideas?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

Starters -

Non broadcasting the SSID is no security at all, it prevents all but the most basic attacks however anyone who can break in to normal wifi, will not be stopped by this.

That aside,

Make sure security is set correctly, I had a client with the same issue as you and it turned out he was using TKIP where as the routers were on AES.

That being said, you said "old laptop", I have one that just refuses to connect to hidden SSID networks, just a sign of old hardware. However, you may be able to go to the site of the manufacturer (Intel, Realtek e.t.c.) and find a updated driver that is supports this.

share|improve this answer
    
I know it's no security, it's a company router, and that's the company's auditor's policy, so they have to do it. –  Kev Sep 4 '09 at 2:30
    
I tried AES and TKIP, neither seemed to make it show up. –  Kev Sep 4 '09 at 2:31
    
I'll try to get an updated driver, thanks--I forgot WU doesn't necessarily cover that –  Kev Sep 4 '09 at 2:32
    
(If you have an auditor who sets policy, maybe check router for MAC filtering) If updated driver does nothing, one thing I found that sometimes works is to enable broadcast of the SSID, set it up correctly then hide... Also, make sure you have checked "connect even if the network is not broadcasting" as that sometimes helps. –  William Hilsum Sep 4 '09 at 2:43
    
It's on the MAC filter, we requested that and it was done/confirmed yesterday. We just double-checked the e-mail right now. –  Kev Sep 4 '09 at 2:46
show 5 more comments

how old? and which type of encryption are you using? the wlan adapter may not support WPA-PSK, only WEP.

share|improve this answer
    
It's a Presario V3000. WPA-PSK. –  Kev Sep 4 '09 at 2:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.