Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every now and then while browsing, my Firefox CPU usage shoots up to the max possible (that's 50% for my dual processor laptop). It remains at max usage even when I close all the tabs. In fact, the Firefox process keeps running even after I close Firefox. I have to go to the Task Manager and close it manually.

I observe this both on my home (64 bit Windows 7) and my work (64bit Windows Vista) computers. Here are the add-ons I have installed on both:

  • Adblock Plus
  • Delicious Bookmarks
  • Ubiquity
  • Xmarks

Does anyone have a solution?

share|improve this question

7 Answers 7

up vote 8 down vote accepted

Yes, mine does it occasionally as well, it is a unacknowledged bug in the latest version of flash.

It doesn't take long to Google and find MANY other people with the same issue (Doesn't matter if you use Chrome, Firefox or IE).

I was browsing the Adobe forum recently and found a page linking to this. Adobe don't seem to support people on their own forums, but pay this company and monitor3complaints here!

I don't know what is causing it as I made a very intensive flash site and the CPU doesn't break a sweat where as a simple small advert on others causes 100% CPU as you report. When I installed Adblock Plus, it blocked these adverts and the CPU was normal.

It doesn't help though on some sites where there is needed flash which causes problems. I have no idea what features in flash actually cause this.

*I know it is flash because as a test I downgraded the version and the CPU never went above 30% on some pages then the moment I upgraded to latest, the same page just jumped to 100%

share|improve this answer
1  
So I guess installing the FlashBlock addon should help? –  Nikhil Sep 4 '09 at 2:00
    
Not heard of that one, but if it does what its name suggests, I guess so! –  William Hilsum Sep 4 '09 at 2:12
    
+1 I've made the same diagnose, and started running adblock just for this. Didn't know about the adobe bug report though. –  Davy Landman Sep 4 '09 at 21:00
    
I prefer Flashblock, and allow flash on sites where it makes sense only. I do run AdBlock but not with a subscription. I don't mind seeing some ads, just not the obnoxious ones. –  kmarsh Jan 7 '10 at 21:19

I disabled the process in add-on manager, then quit Firefox and re-enabled it.

This worked, but I don't know how long it will last. It's worth a shot though.

share|improve this answer

I checked my extensions as suggested by PhiLho above and found an "Ask.com toolbar" that I had not knowingly installed. I uninstalled it and the problem is gone.

share|improve this answer

Guess you also have a couple of Java plugins installed, go to about:plugins page to verify this.

I'd suspect one of them

share|improve this answer

I had this problem on one computer (and only this one), Googled a lot, found various "fixes", none really worked...

Upgraded to Firefox 3.5... problem gone.

share|improve this answer

Guess what, for me it was AVG safesearch in the Extensions tab. Problem Gone. Stupid AVG.

share|improve this answer

The solution to this issue us simpler than many so-called solutions I have found.

Step 1 - Go to Help/Troubleshooting Information on the Firefox menu

Step 2 - Find and press 'Reset Firefox' under the Reset Firefox to Default State area

My CPU usage dropped from over 90% to under 10% immediately and has remained so.

This is necessary on a basis that is determined by individual usage.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.