Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Ubuntu 11.04 (classic). The laptop is getting very very hot and often it shuts down due to over heat.

When I use Windows on the same laptop (dual boot) its fine and heat is almost ignorable.

I'm using HP probook 4520s


  • RAM:4GB
  • Processor:core i3 (2.26 GHz, 3 MB L3 cache)
  • Graphics:ATI Radeon HD 4350

Is there anything I can do to reduce the heat while running on Ubuntu? If there is no good way of doing that I dont mind switching to other linux distro using gnome.

PS: I hate KDE. LXDE,XFCE aren't matured like gnome.

share|improve this question
Most likely, your BIOS settings don't do select any reasonable power management and all your power management was specifically configured in Windows. Linux, by default, honors the BIOS settings. – David Schwartz Nov 6 '11 at 16:12
up vote 0 down vote accepted

Since you are using gnome, you can add the cpu frequency scaling monitor to to your panel and manually decrease the cpu frequency. There is a new version for Unity, so don't mix those up.

The fact that it overheats and shuts down due to heat seems to indicate that something else might be wrong. Maybe your fan and heat sink are clogged with dust? Maybe Windows intelligently down throttles the cpu due to heat while ubuntu does not?

I'm using Ubuntu 11.10 and it seems to run a little hotter and use up more battery than windows... even with everything on the lowest settings. Not sure whats going on there.

share|improve this answer
Thanks fr the quick reply. 'sudo dpkg-reconfigure gnome-applets' is not prompting anything as shown in the link you've given – dotslash Nov 6 '11 at 8:09
@dotslash I actually don't remember having to do that particular step. Does it seem to work without adding root privileges to it? You can type 'cat /proc/cpuinfo' in the terminal to see what frequency it is set to. – James T Nov 6 '11 at 8:18
tried that , but the heating is as high as it was before. – dotslash Nov 6 '11 at 9:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .