Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

One of our windows 7 laptop cannot connect to wireless LAN where as other laptops are able to connect to wifi without any troubles. When ethernet cable is connected and wireless connection is turned ON, it says WPA-PSK2 signal is active with 54 mbps. Wireless LAN adapter is getting an ip address of 10.10.10.1 and ethernet adapter with 10.10.10.2. I tried to ping both address from the modem and there was 50 %, 75 % and 100 % packet loss to wireless adapter and ethernet adapter has no issues. We use a special dns addresss supplied by the ISP and ethernet LAN internet connection is working ok. I tried to ping other computer when wireless LAN only is enabled, it couldnt ping to other computer on the network. So there should be some problem with wireless adapter and drive? But when i took that laptop to different wireless wifi, it is connected without any problems.

share|improve this question

migrated from serverfault.com Nov 6 '11 at 22:35

This question came from our site for professional system and network administrators.

    
When dealing with network issues, you have to consider both the access point (router) and the adapter (PC). If you can connect to others wireless networks, then most likely the wireless settings on your PC are not configured correctly for your network. –  iglvzx Nov 7 '11 at 15:47

1 Answer 1

A little bit more detail could be useful here. Specifically, what kind of router are you using? What kind of firmware on the router? Who made your wireless card? Just to be clear, is that packet loss you mentioned (50%,75%, and 100%) when your computer is plugged in via Ethernet, or is it occurring when your computer is only connected with WiFi? Have you

I doubt you've got a drive problem, considering that your ethernet works just fine and you're not reporting any symptoms traditionally associated with hard drives. The fact that the problem exists only on your network suggests that the problem has been created by some sort of conflicting settings, so I'll try and provide some guidance for resolving those.

Assuming that all your software is up-to date, try disconnecting from the network, then deleting it from your computer's list of remembered networks. Then try to reconnect.

If you're still having difficulty, try checking out the Event Viewer in Windows, and see if there's anything useful there. Also, check to see if your router has logging enabled. If that's the case, see if it's reporting any exceptions when you try to connect. With only your question to go on, I can't really provide much more detail. A reinstall of Windows could be worth a try, but it's a pain, so I'd use that as a near-to-last resort.

share|improve this answer
    
The ethernet and wireless adapters usually do not use the same drivers. –  iglvzx Nov 7 '11 at 15:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.