Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This weekend I upgraded my Dell XPS laptop from XP to Windows 7, and I also installed IE9 (which doesn't run on XP). I experience often rendering problems, like text not rendering at all, or rendering warped like this:

enter image description here

Do other users experience this too?

This is bad enough as it is, but my laptop often crashes with a BSoD, with a memory parity error. I have the distinct impression that this is also IE9 related. I've run MemTest86+ which didn't report any errors. Can one application cause memory errors when others don't? Can I tweak the memory settings to get rid of the BSoD?

edit
weberik suggests the video RAM may be faulty. Is this possible if all other applications display correctly. Same for the driver; while I had to install a Vista driver (there don't seem to be Windows 7 drivers for the XPS M1710) it works well for other applications.

another edit
The pages display correctly in Firefox, and, BTW, also sometimes in IE9. I created a test page, just content, no styles, and it seems to behave, until I resize the window, and then the top or bottom half of complete phrases is cut off (shows as white). At least it doesn't seem to crash anymore. Printing works for the simple test page, but more complex pages print garbage; just the text itself, the layout is OK.
I call IE bugs. The pages are valid HTML and CSS, and show in another browser as designed, no problems there, not with fonts nor anything else.
While I can understand there could be problems with the rendering engine I can't explain the crashes. Could it be that IE9 tries to address non-existing memory? Memory requirements will be different between the simple test page and the rest of my site. My system has 2GB of RAM. (It used to have 2.5GB, but I removed the 512MB module, to be sure that that wasn't the culprit.)

share|improve this question
    
IE9 makes use of hardware acceleration for rendering and considering that you mention you're using Vista drivers, I'd say it's a driver problem –  Sathya Nov 7 '11 at 14:24
    
@Sathya - turning off GPU rendering seems to help (keeping fingers crossed). Could you make your comment into an answer, so that I can upvote it, and accept if it solves the problems definitively? –  stevenvh Nov 7 '11 at 14:41
    
sure, fleshed out into an answer. Hope that fixes your problem! –  Sathya Nov 7 '11 at 14:47

3 Answers 3

up vote 3 down vote accepted

IE9 makes use of hardware acceleration for rendering. Since you're using Windows Vista drivers instead of Windows 7, that might be causing the rendering corruption.

You mention that Windows 7 drivers aren't available - consider disabling Hardware Acceleration & force software rendering:

To disable hardware acceleration and use software rendering instead of hardware rendering to view the webpage, follow the steps below:

  • Click Start, Control Panel, Network and security and then click Internet Options
  • Click the Advanced tab, and then browse to the Accelerated graphics section.
  • Click to select the Use software rendering instead of GPU rendering check box.
  • Click Apply, and then click OK.
  • Close all open Internet Explorer 9 windows, and then restart Internet Explorer 9.
  • View the webpage in Internet Explorer 9.
share|improve this answer
    
Thanks. BTW, Internet Options are also available from within IE, under Tools. That's where I found the GPU rendering checkbox. Do you know a real heavy website where I can do more load testing? I tried the Acid3 test, but that just tests compliance. –  stevenvh Nov 7 '11 at 15:01
    
@stevenvh have a look at Chrome Experiments they are designed to work on Google Chrome, but should run on IE9 as well –  Sathya Nov 7 '11 at 15:10
    
Seems be fixed. At least I could visit several sites and IE is still there after a couple of hours; with GPU rendering it would crash within a minute or so. –  stevenvh Nov 7 '11 at 16:57

looks like a problem with your graphics card.

my guess would be either the driver or the RAM

make sure you use the most recent driver and play around with the settings a bit (acceleration on/off).

share|improve this answer
    
Thanks. The PC is somewhat old and I only found a video driver for Vista. Could this have to do with it? Also, since other programs work well, is this an IE9 or a driver problem? –  stevenvh Nov 7 '11 at 11:44
    
Could the BSoD error also be due to the video? I don't expect video memory to have parity check. OTOH, it would explain why MemTest86+ didn't find errors. –  stevenvh Nov 7 '11 at 11:46
    
Drivers designed for Vista x86 or Vista x64 should work without issue on Windows 7 x86 and x64. –  Ramhound Nov 7 '11 at 13:30
    
yes the driver/mem problem could also cause the bluescreen. –  weberik Nov 7 '11 at 14:06
    
do you have a spare gfx card? or maybe a second one in your pc (like an onboard card)? just switch, install the driver and check if the problem persists. its the only definitive way –  weberik Nov 7 '11 at 14:14

Do the BSOD only occur when IE9 is running? Try resetting IE9's settings: Internet Options > Advanced tab > Reset (at bottom right).

Do the same pages render incorrectly in other browsers? If so, perhaps reinstall the font. If you print the page, does it display incorrectly also? This might imply it is font-related.

Try setting IE9 to use your own style sheet, and setting the font to one which you know displays ok on other websites.

  1. Create a vanilla style sheet.
  2. Goto Internet Options > General tab > Accessibility
  3. Click the check box for "Format documents using my style sheet".
  4. Browse to your style sheet and choose it. Then click "OK" twice to get out of the Internet Options menu.
  5. Close your browser and re-open it. Your styles will be applied to all pages you visit after that.

Your stylesheet might be as simple as:

body {font-family: arial, sans-serif; font-size: 1em }

Perhaps add elements which you can identify as being displayed incorrectly in some webpages, and see if you can determine if the problem webpage specifies a specific font. Set a different font in your style sheet.

share|improve this answer
    
Thanks Steve. Resetting doesn't help. Pages render well in FF7, but print garbage from IE9. –  stevenvh Nov 7 '11 at 14:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.