Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I enter, say, xyz.test in the Chrome address bar, then Chrome initiates a search. How do I make Chrome always treat .test as a top level domain, just like .com and all the others?

I know that I can just put http:// in front, but I tend to forget that, especially when editing an address that has already been entered. By the way, that's another annoyance: I would like to have Chrome always show the http:// in the address bar.

share|improve this question
1  
Part of that question overlaps at least one existing SuperUser question. –  JdeBP Nov 7 '11 at 12:55
    
No overlap: The user who posted the question enters http://. I don't want to enter http:// at all. –  feklee Nov 7 '11 at 17:20
add comment

1 Answer

up vote 0 down vote accepted

Just found out that the iglvzx's proposal, sent in reply to another user's inquiry, offers a partial workaround:

You can implicitly do this by creating a new search engine with a URL of http://%s and keyword of null. Then, set this as the default search engine.

I say partial workaround since now the default search functionality in the address bar is entirely disabled. For the time being, I marked my answer as accepted. But I may change that, if someone offers a better solution!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.