Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Windows XP machine recently started to semi freeze on me every odd reboot after a few minutes of usage (different programs / no additional prg start at all).


Update: I have now managed to get a bit more detail with Process Explorer. This is a 2 core CPU and the 100% kernel usage is only on one core. The process list shows DPCs - Deferred Procedure Calls at 50% (that's 100% on one core). So the question is now: **What's DPC and how do I fix them??


Next update: OKIES ... using this and that I have been able to get xperf running on my Windows XP, and the sample dumps I took display just fine on my Win7 laptop.Yes, you need a Win7/Vista computer to view the dumps taken on Windows XP. However, I am now facing the following problem, I can enable xperf tracing, xperf -on Latency and the problem now also reoccurred while xperf tracing was on, but as soon as my DPC goes to 100%, Windows doesn't start any new processes (or their startup never finishes) (an open e.g. cmd window remains responsive just fine, but every exe you try too call just hangs (dir works just fine because that a cmd command) -- I can only assume that CreateProcess hangs with some part of the kernel). Now, not being able to launch any new process means that I cannot run xperf -d dumpfile.etl, because, when I enter that on the cmd window, it just hangs.

So it seems I'm out of luck here. I would rather throw out the whole rig than start manually disabling drivers ... :-)

Any other ideas appreciated!


That is, while Windows remained responsive theoretically (e.g. Mouse Cursor moved normally and I could click, and the click was eventually recognized) actions taken by the user were only responded to after minutes (literally).

Example: Hitting the Num-lock key on the keyboard normally toggles the Num-lock LED on the keyboard. This also is the case with my semi-frozen machine, but only after a minute or two.

One time, I managed to launch Process Explorer and, after a few minutes, the System information graph clearly indicated 100% CPU usage on the red line (kernel mode) and the green line stayed on zero. In this state, though the graph was still updated on screen, the machine could not be operated anymore. (Well, unless you are willing to wait for a few minutes after every click.)

So, now I'm wondering what the problem could be, as I did not install anything new on this machine for weeks, certainly not prior to seeing this behavior. (Rebooting helps sometimes, sometime I need a second or third reboot before the machine becomes usable for a longer period of time.)

Now, how can I find out what is actually causing the excessive kernel mode usage?


Note: Also posted this in the sysinternals forums.

share|improve this question
    
One way would be to use the process of elimination. In XP run the MSCONFIG program and go into the STARTUP Tab and disable all, then reboot and see if that fixes it. If it doesnt, try a program like AUTORUNS or HijackThis and get more agressive about elimination. Once you have operations back, re-enable things one at a time. 90% of the crap that runs at startup is not nesssiary the other 10% is junkware :-) –  Psycogeek Nov 8 '11 at 8:40
    
@Psycogeek - appreciated. I'd rather not do this, as that would take me days I don't have :-) –  Martin Nov 8 '11 at 9:19
    
ahh its minutes to disable startup junk, it is days to disable Device drivers :-) when i try and hone in on your problem, using your whole set of clues, it actually sounds more like some virus type stuff. but could easily be some device that is not responding. Got any stuff stuck externally you can temporarily remove? did you run a check of the disks, like say a S.M.A.R.T test of the drives. to see if you get any clues from that? –  Psycogeek Nov 8 '11 at 9:31
    
Ok so now (dpc) I'll have to check the stuff here: superuser.com/q/202254/50211 and see whether I can get to the bottom of this. –  Martin Nov 22 '11 at 20:49

1 Answer 1

You can find out which DPC routine is causing the freezes by using a tool like LatencyMon (http://www.resplendence.com/latencymon). Simply look for the DPC routine taking the longest total time.

share|improve this answer
    
Clearly, LatencyMon doesn't work in windows XP. And the question is about a performance issue in Windows XP system. –  Edward Feb 24 at 17:30
    
I was not aware of that - thanks. My suggestion is still the same though - just use a different program instead which does. One example: DPC Latency Checker (thesycon.de/deu/latency_check.shtml). –  Zero3 Feb 25 at 0:13
    
Actually, the features of LatencyMon is far better/easier to use for end users than Latency Checker. LatencyMon analysis system and provide very detailed info, to the level which driver consume the most resource, which one make worst effect to system performance. Another side, Latency Checker just display a graph which only give you most basic info. That's your system out of DPC latency or not. Further works are all in your own. I'm in trouble finding a equal/similar tool for XP, that works the same way as LatencyMon. –  Edward Feb 25 at 4:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.