Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have some macro enabled word documents that worked fine in Word 2003, but in 2010 I cannot get the macro security settings to behave properly.

When I first open a macro enabled document, I get this popup: enter image description here

At the same time, along the top of Word, just under the ribbon, this bar appears: enter image description here

After clicking [OK] on the first warning, the "Security Warning" prompt bar dissappears, so I cannot click the [Enable Content] button. This issue occurs even when the file resides in a network location that is trusted. The only fix I've been able to come up with is to enable all macros on all documents, but obviously that isn't the safest way of doing things.

I've tried changing numerous setting combinations in the Trust Center, but still have the same problem. Any ideas?

share|improve this question

2 Answers 2

This sounds like an issue with the macro itself. You should check the macro for depreciated commands and functions.

share|improve this answer
    
Thanks for your reply. I wasn't able to troubleshoot this issue for a few weeks, but I got around to testing today. I've gone through the code and haven't been able to find anything that's considered depreciated. Any other ideas? –  dmux Nov 29 '11 at 21:01

Not sure if you are still watching this thread but I had this same issue. It was because I had an auto open macro in a template. What was happening is the auto-open macro was trying to run before I click the button to enable macros. Unfortunately the box to enable macros is disabled until you click the error (as you show above). You can confirm this behavior by holding shift when you open the document to skip auto-run macros. Then you can go to view...macros... and run the auto open manually.

If you add the template to the trusted sites list it should enable macros for the file before opening the doc, however you wont get the prompt. I am still trying to figure that out, e.g., prompting me to enable, before trying to execute the autorun.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.