Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been using win32 emacs on windows 7 pretty regularly for the past year almost... however it has suddenly stopped working. When I execute 'runemacs', nothing happens. I can see the process has begun in the task manager, but the CPU & memory usage are unchanging.

I haven't added any new software etc... there are no network paths in my $PATH environment variable.

I've even deleted the init.el file, to no avail.

Is there a way to start emacs in a debug mode to see where it could be getting stuck?

Thanks, Arjun

share|improve this question

migrated from stackoverflow.com Nov 7 '11 at 22:56

This question came from our site for professional and enthusiast programmers.

add comment

3 Answers

Try passing the -debug-init flag on the command line. Though, I don't know if this will work in windows.

Other thoughts, I have a feeling runemacs.exe might be trying to run emacsclient or one of the other exe's in the bin directory. Try running emacs.exe directly instead.

share|improve this answer
add comment

You can use any debugger if You are familiar with it(like olly). Also, you can try to rollback the OS to time when it worked.

share|improve this answer
add comment

Try

emacs -no-init-file 

to see if the problem is caused by something in your .emacs

also

emacs --debug-init

to see if you get any debug output

If that doesn't help try

emacs --nw 

to see if it's display related

Finally, and I think this may be it, try to run as administrator (right click runemacs.exe in explorer and choose run as administrator) to see if there is a problem with file permissions. Windows 7 is a lot more fussy about file access in the Program Files (x86) folder for example.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.