Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7 won't reconnect to my network drives on startup.

Once it is done booting opening Windows Explorer and clicking each share will mount them.

Windows 7 Enterprise N Service Pack 1

I have attempted formatting the windows machine - first thing done to machine was to map the network drives, upon reboot they were disconnected. It is running on an Crucial M4 64gb SSD.

The host of the network shares is a Ubuntu-Server machine connected through a gigabit switch. A modem provides dhcp, although both these machines have static IP's defined.

It won't reconnect the drives regardless of whether they're SAMBA shares or NFS shares - therefore I believe it's an issue with the windows machine.

Ubuntu 11.10 (GNU/Linux 3.0.0-12-server x86_64)

I've tried using ip address instead of netbios name for mapping shares on the windows machine,

Also tried setting EnableLinkedConnections=1

gpedit.msc > Computer Configuration - Administrative Templates - System-Logon - always wait for the network at computer startup and logon = yes

share|improve this question
    
You should post the error from Event Viewer. For all we know, your network port doesn't magically turn on until 20 seconds into login. . . –  surfasb Nov 8 '11 at 9:49
    
Gateway resolution failed on interface {8e9717be-da36-457d-80e0-6c146377100c} for 192.168.1.1 with error: 0x43 –  Thermionix Nov 9 '11 at 9:17
    
@Thermionix Were you ever able to find a solution to this issue? –  Dev Mar 14 at 0:40
    
Yeah; stopped using windows –  Thermionix Mar 14 at 1:06

2 Answers 2

Use the Credential Manager and specify an "Enterprise" persistence username+password

http://windowsforum.com/threads/could-not-reconnect-all-network-drives-problem.3262/

  1. Goto Control Panel -> All control Panel Items -> Credentials Manager
  2. Next to the heading "Windows Credentials" click on the link "Add a Windows credential".
  3. Enter the name of your NAS server ("NAS" in my case) and the appropriate credentials.

The result is an entry that has a persistence type of "Enterprise". This seems to do the trick. (I then restarted windows)

share|improve this answer
    
Unfortunately my credentials for access to the share are already saved in Credential Manager with 'Enterprise' persistence –  Thermionix May 2 '12 at 0:57

When I had this problem I resolved it by unchecking the Connect using different credentials check box when mapping the network drive. This allowed the network drives to reconnect at Windows startup.

enter image description here
click to enlarge

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.