Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently lost the default file association for Zip files in Windows Vista (I think it happened when I uninstalled WinAce, but I can't be completely sure). How can I restore this association back to the Windows default?

share|improve this question

7 Answers 7

up vote 34 down vote accepted

Try this article from MSDN: How to restore the native Zip file integration in Windows. You only have to do this from an elevated (run as administrator) command prompt:

cmd /c assoc .zip=CompressedFolder
share|improve this answer
1  
That link refers another article (windowsxp.mvps.org/zipfldr.htm) which says you may need to do the regsvr32 step from my answer first and use this association if that does not suffice. –  nik Sep 4 '09 at 7:42
    
This works in Windows 7, but doesn't seem to restore the icon –  Casebash Apr 8 '10 at 23:34
4  
It restored the icon for me in Windows 7, but what was not mentioned for me is that you need to run cmd as Administrator. –  Curyous Mar 24 '11 at 21:50

The first post is the long way to perform this three step process... Here is a simple and easy way to change the file association back to Windows Explorer:

  1. Locate the file

  2. Right click the file

  3. Click properties

  4. Locate the "open with" button and click it

  5. Browse to the windows explorer to "c:\windows\explorer" and highlight the explorer file

  6. Check use as default-apply-ok

share|improve this answer

I had the same problem and this worked for me:

  • Click the Windows Orb (Start) > All Programs > Accessories and right-click Command Prompt, then "Run as Administrator".
  • Type assoc .zip=CompressedFolder and press Enter.
  • You may have to restart the computer.
share|improve this answer

This works for me in Windows 7:

  1. Remove

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.zip
    HKEY_CLASSES_ROOT\.zip
    
  2. cmd /c assoc .zip=CompressedFolder

End Result:

[HKEY_CLASSES_ROOT\.zip]
@="CompressedFolder"

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.zip]
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.zip\OpenWithList]
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.zip\OpenWithProgids]
"CompressedFolder"=hex(0):
share|improve this answer

The best way is to try using the Open With... context menu to set Explorer to be the default file handler.

However, if that does not work you can try the following to force Explorer to handle ZIP file. (Source for this info)

Make a .reg file with the following:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.zip]
"PerceivedType"="compressed"
"Content Type"="application/x-zip-compressed"
@="CompressedFolder"

[HKEY_CLASSES_ROOT\.zip\CompressedFolder]

[-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.zip\UserChoice]

[HKEY_CLASSES_ROOT\.zip\CompressedFolder\ShellNew]
"Data"=hex:50,4b,05,06,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00
"ItemName"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,\
6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,\
00,7a,00,69,00,70,00,66,00,6c,00,64,00,72,00,2e,00,64,00,6c,00,6c,00,2c,00,\
2d,00,31,00,30,00,31,00,39,00,34,00,00,00

[HKEY_CLASSES_ROOT\.zip\OpenWithProgids]
"CompressedFolder"=""

[HKEY_CLASSES_ROOT\.zip\PersistentHandler]
@="{098f2470-bae0-11cd-b579-08002b30bfeb}"

[HKEY_CLASSES_ROOT\CompressedFolder]
@="Compressed (zipped) Folder"
"FriendlyTypeName"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,\
00,6f,00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,\
32,00,5c,00,7a,00,69,00,70,00,66,00,6c,00,64,00,72,00,2e,00,64,00,6c,00,6c,\
00,2c,00,2d,00,31,00,30,00,31,00,39,00,35,00,00,00

[HKEY_CLASSES_ROOT\CompressedFolder\CLSID]
@="{E88DCCE0-B7B3-11d1-A9F0-00AA0060FA31}"

[HKEY_CLASSES_ROOT\CompressedFolder\DefaultIcon]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,7a,00,69,00,\
70,00,66,00,6c,00,64,00,72,00,2e,00,64,00,6c,00,6c,00,00,00

[HKEY_CLASSES_ROOT\CompressedFolder\shell]
@="none"

[HKEY_CLASSES_ROOT\CompressedFolder\shell\find]
"SuppressionPolicy"=dword:00000080

[HKEY_CLASSES_ROOT\CompressedFolder\shell\find\command]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\
65,00,00,00

[HKEY_CLASSES_ROOT\CompressedFolder\shell\find\ddeexec]
@="[FindFolder(\"%l\", %I)]"

[HKEY_CLASSES_ROOT\CompressedFolder\shell\find\ddeexec\application]
@="Folders"

[HKEY_CLASSES_ROOT\CompressedFolder\shell\find\ddeexec\topic]
@="AppProperties"

[HKEY_CLASSES_ROOT\CompressedFolder\shell\Open]

[HKEY_CLASSES_ROOT\CompressedFolder\shell\Open\Command]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\
65,00,20,00,2f,00,69,00,64,00,6c,00,69,00,73,00,74,00,2c,00,25,00,49,00,2c,\
00,25,00,4c,00,00,00
"DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"

[HKEY_CLASSES_ROOT\CompressedFolder\ShellEx]

[HKEY_CLASSES_ROOT\CompressedFolder\ShellEx\ContextMenuHandlers]

[HKEY_CLASSES_ROOT\CompressedFolder\ShellEx\ContextMenuHandlers\{b8cdcb65-b1bf-4b42-9428-1dfdb7ee92af}]
@="Compressed (zipped) Folder Menu"

[HKEY_CLASSES_ROOT\CompressedFolder\ShellEx\DropHandler]
@="{ed9d80b9-d157-457b-9192-0e7280313bf0}"

[HKEY_CLASSES_ROOT\CompressedFolder\ShellEx\StorageHandler]
@="{E88DCCE0-B7B3-11d1-A9F0-00AA0060FA31}"

Then, in an admin command prompt type:

regsvr32 zipfldr.dll

One other suggestion I have seen is to simply go into the Default Programs editor in Control Panel and removing the association you currently have. However, this was for XP and I'm not sure that it will work for Vista. However, you may want to try this before playing around the registry.

share|improve this answer
    
Oh my -- surely there's an easier way. I already tried removing the past associations (or rather, adding some back and then removing them, since there was nothing of value there once I got to looking.) –  Brian Sep 4 '09 at 5:28

The quickest way is to get any .zip file and right click on it, go down to "Open with" and choose "Choose Default Program" or "other" then on this box, you should see "Windows Explorer" or whatever you used to use listed.

Click the button "Always use the selected program to open this kind of file" at the bottom and then double click on the program you want to use.

This should then open up ZIP files in a new default program.

If this method does not work, I can give you the manual instructions for reassigning .zip with Explorer, but this is by far the quickest.

share|improve this answer
    
No dice. Already tried to manually associate Zip files with explorer.exe, and the that sort of worked, but it didn't restore the "Extract All" context menu, or the general "treat zip files like folders" functionality. –  Brian Sep 4 '09 at 5:25

Try binding the Windows Compressed Folders Module directly,

start regsvr32 zipfldr.dll

Or, you could just install 7-zip which is free and much more powerful.

share|improve this answer

protected by slhck Aug 20 '13 at 15:09

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.