Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've run into a problem with Google Chrome on my laptop (my desktop machine, apparently an identical Windows 7 installation doesn't have the problem). On some sites, Chrome fails to render text correctly, instead substituting seemingly random characters. Here's an example from the Opera browser web site, http://www.opera.com/:

Text correctly rendered by Firefox

(Text correctly rendered by Firefox)

Text incorrectly rendered by Chrome

(Text incorrectly rendered by Chrome)

I've reinstalled Chrome, and checked that the fonts are defaults; Encoding is set at auto-detect (UTF-8). What else can I do to fix this?

Thanks.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

The Win7 has implemented a new font system. I dont totally understand it yet, but problems like this can occur when a font is replaced, or is just working in place of the provided font items.

Here is the only explaination I can do so far: The new fonts can have layers of typefaces in them, notice how Large thier file sizes are. These layers can have multiple fonts and bold and ital and even other fonts and languages in them. The previous font were simple small and uncomplicated. If one of these fonts this web header is using (view the web source code) Was replaced or just hanging out there being used, instead of the system finding the type it was thinking was there, it would show what is in this replacement font item.

http://support.mozilla.com/en-US/questions/702002

Get into your fonts folder (preferably with something that actually shows "details", but getting in with winders might show you) And compare the 2 font folder structures between the machines. and delete away :-) . the system protects the primary system fonts, sooo you cant do to much damage :-) but having a backup before deleting stuff comes in handy .

Then it wouldnt hurt to clear the font cache, after you find that weird font that dont belong, or even do that First to try and fix it by just clearing the font cache thing.

http://www.sevenforums.com/browsers-mail/170031-chrome-messed-up.html

Alternativly and for testing, you could use whatever resources they provide in the program to ignore the websites fonts, and force your own font in.

side notes: Fonts can also be set by the web pages CSS style sheet, so if you cant find the offending item in the webs "source code" then you can find it in the style sheet that came in with the web site. The purpose of knowing the web source font used, would be to know which font it likely is that has been replaced or is overriding.

share|improve this answer
    
Turns out Helvetica Neue was causing the issues. Installed it on the desktop and that PC did the same thing. Interestingly, Firefox wasn't using the installed font, but falling back to Arial. –  Iain Hallam Nov 9 '11 at 11:31
    
Just for Info sake, do you happen to know what installed the font on your system? –  Psycogeek Nov 10 '11 at 1:17
    
Unfortunately, no. The laptop tends to receive fewer installs than my desktop, so I'm not quite sure why it had an extra font. –  Iain Hallam Nov 10 '11 at 13:38
    
I'm having this same issue. I had Helvetica Neue, which I've subsequently deleted (along with the font cache, then rebooted), but it's still showing the weird characters on some sites. Any ideas how to find the other fonts that might be causing this? –  JoshSamBob Aug 15 '12 at 20:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.