Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using firefox 7.0.1. and noticed that it kept on defaulting to using yahoo as its search engine. I then tried selecting "Manage search engines..." and deleted all of them other than google. Sadly when I shut firefox down and restarted it, yahoo was added to the list and was the default. I have no idea how to stop this.

share|improve this question
    
Do you have a Yahoo! toolbar installed? Right click next to the menu and see what toolbars are listed in the context menu. – ChrisF Nov 8 '11 at 12:13
    
No, the yahoo toolbar was not installed. – Mick Nov 13 '11 at 10:52
up vote 3 down vote accepted

Just discovered it was caused by the pdfforge toolbar. Uninstalling it removed the problem.

share|improve this answer

Just had the same issue despite pdfforge toolbar being disabled (and I can't seem to uninstall it).

The magic about:config item that does this seems to be keyword.URL:

Changing the Internet Keyword service

You can specify any valid URL to perform the Internet Keyword searches by modifying the keyword.URL preference in the about:config page:

To use the Browse by Name service from in earlier versions of Firefox, keyword.URL can be set to http://www.google.com/search?ie=UTF-8&sourceid=navclient&gfns=1&q=. Google will forward you to the relevant site if it finds a clear match. Otherwise, the search results page will be displayed.

To use Yahoo!, set keyword.URL to http://search.yahoo.com/search?p=, Bing, set it to http://www.bing.com/search?q= and so on. To reset the Internet Keyword service to use a standard Google search, right-click on keyword.URL and select Reset.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .