Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been trying to install virtual systems on VMWare for a while now and encountered strange behaviour from my PC.

The behaviour is as follows:

  • On "automatic" virtualization mode it either outputs a cryptic error message (can MAYBE give later, if I can reproduce) right on startup (before even the BIOS) or it resets the complete HOST system (blackscreen, bios...)

  • If I install a Windows XP on it it works well on "binary translation" mode.

  • If I try installing Linux on it, in "binary translation" mode it crashes 1 or 2 seconds after I hit enter on the GRUB selection screen (after the first page of kernel messages rolled in)

  • Using VirtualBox it crashes right in the BIOS. It gave me a Bluescreen though! 0x00000101: CLOCK_WATCHDOG_TIMEOUT: a clock interrupt was not received on a secondary processor within the allocated time interval

  • NEWS: I tried VirtualBox again and it did not completely crash the computer this time. It gave me a critical error and a log file:

  • In conclusion, it will crash instantly if VT-x is activated. If not, it seemingly only crashed if I try to install something with 64 bits.

  • Another update: Yes, it ONLY crashes when the guest is 64 bit!

  • On Linux using VirtualBox, it crashes with a Kernel Panic.

What I tried:

  • Reinstalling Windows (my Windows installation was quite broken so it seemed natural. Didn't work though.)
  • New BIOS

What I am certain of:

  • Virtualization extensions are activated in the BIOS

What my computer specs are:

  • ASUS P8P67 LE mainboard, newest BIOS/EFI firmware
  • Intel Core i5 2500k
  • Ati Radeon HD 5770
  • 16 GB Corsair 1333mhz DDR3 RAM, 4 X 4 GB
share|improve this question
Are you using dual channel or a single stick? – HaydnWVN Nov 8 '11 at 16:35
4 sticks a 4gb in total – sinni800 Nov 8 '11 at 16:47
You can try VirtualBox to see if it gives the same error. – Joe Internet Nov 8 '11 at 16:58
@JoeInternet Seems that I have to. – sinni800 Nov 8 '11 at 17:16
VirtualBox crashes in similar ways. Right in the BIOS for example. BUT I have finally gotten a bluescreen: 0x00000101: CLOCK_WATCHDOG_TIMEOUT. Hell – sinni800 Nov 8 '11 at 21:25
up vote 0 down vote accepted

If you have a spare hard disk laying around you could try install a copy of Linux like Ubuntu. After Linux is installed try installing VMware or Virtualbox and see if the error presists. What this would rule out is hardware malfunction.

Another thing you could try but would be much more complex would be to run a copy of VMware ESXi and make the machine into a temporary server and once again see if the problems still presist.

Something that has just crossed my mind, what is the specs of one of you virtual machines?

Are you allocating all system resources to the VMs or are you holding back?

For example I only use 1 vCPU in my VM(s) so there is still one available for the main system, granted I am only running 1 VM at a time but you get the idea.

share|improve this answer
1 CPU, 1 gbyte of ram. I have 16 GB available, so... Should not bother my system at all. I will try running a Linux on a seperate hard drive though. – sinni800 Nov 15 '11 at 13:48
Im on my fresh linux system now. CentOS Linux release 6.0 (Final) – sinni800 Nov 15 '11 at 16:11
Whats the word? Does it work? – ianc1215 Nov 16 '11 at 5:30
Okay I got to try it now. I started virtual box, started a virtual machine, and, KERNEL PANIC. If anyone knows how to debug anything out of the kernel crash file in /var/crash, I'd be pleased. I used the crash binary to open the crash file, resulting in a GDB instance. But now I dont know what to do. Still, seems to point towards hardware failure.. Damn. Or BIOS... Any of that – sinni800 Nov 16 '11 at 15:34
It seems like you may need submit an RMA to ASUS for the motherboard. I guess that is where the problem is. On a side note by any chance is the processor overclocked? That might lead to the problems in some way. – ianc1215 Nov 17 '11 at 1:26

Ensure all your host's drivers up-to-date with the latest version available from the manufacturer(s) (Chipset, RAID, Video, etc.). I'd recommend getting the latest drivers directly from Intel, instead of trusting Asus to have the latest posted.

Clock_Watchdog_Timeouts are often/usually caused by a kernel-level thread (say, in a HDD controller driver) that's gone into a Spinlock. That error in combination with the fact the host is resetting tells me there's either a driver problem for a piece of the host's hardware, or a piece of hardware on the host is malfunctioning.

share|improve this answer
+1 -- this is definitely some kind of faulty hardware – Billy ONeal Nov 15 '11 at 3:29
But no computer test I have ever tried has ever returned a fault. I'll be on the Intel site and download everything new now. Edit: Video drivers from ATI are the latest, Chipset (Intel INF installer) didnt install anything (was current), Rapid Storage Drivers were new ones from three days ago! Fingers crossing. – sinni800 Nov 15 '11 at 13:49
After trying with VT-X enabled it crashed... In the bios, with a 0x00000124 WHEA_UNCORRECTABLE_ERROR error. – sinni800 Nov 15 '11 at 14:22
You have a hardware error: "The WHEA_UNCORRECTABLE_ERROR bug check has a value of 0x00000124. This bug check indicates that a fatal hardware error has occurred. This bug check uses the error data that is provided by the Windows Hardware Error Architecture (WHEA)." Short of spending a lot of time debugging with WinDBG and such just to find a potential culprit, your best bet is going to be to start trying replacement parts (Video, RAM, Motherboard, etc.). If you don't have the test parts, then you may need to take it to a shop. – Ƭᴇcʜιᴇ007 Nov 15 '11 at 16:34
I hoped it would never come that far, but it really seems that my hardware is malfunctioning – sinni800 Nov 16 '11 at 15:36

Very odd issues and a wide range of OS's causing errors (and your description of a cryptic error message) would make me want to test the RAM using something like memtest from Hirens Boot CD.

share|improve this answer
Sorry, I forgot to state that a) I have had no other bad experiences with it and b) I have run a nightlong memtest before, not long ago. I think I can safely say that the ram is intact – sinni800 Nov 8 '11 at 16:47
As a simple 'test' just run 2 of your 4 sticks and see if it behaves better - it might be some weird problem with your motherboard, 16gb of ram and Corsair chips. Can't think of much else to try except lowering memory timings if they're specified or specifying them if they're on auto... – HaydnWVN Nov 8 '11 at 16:52
I received the other two sticks a week ago, the problem was there before :). The timings... I never cared about setting timings. I always left them at auto.. So I don't know what I would set them to – sinni800 Nov 8 '11 at 17:17
Ahhh ok, tried it without your old sticks in? – HaydnWVN Nov 9 '11 at 10:00
It doesn't really change anything. It seems the error is somewhat related to since I also use virtualization when this occurs... Huhl – sinni800 Nov 9 '11 at 10:07

I see in the log the message :

Installed Extension Packs:
   None installed!

This might relate to the Oracle VM VirtualBox Extension Pack explained here.
Installing it might be useful (I don't like the exclamation point on the message above).

share|improve this answer
I'm sorry, no. It didn't change anything. It just added support for a few things like PXE roms, USB 2.0, ... and didn't change anything at the core of VirtualBox. – sinni800 Nov 13 '11 at 20:40

A somewhat incoherent last answer in this thread says for a virtualization problem on same-make board :

i figured now that in bios it was necessary to disable something called "executed bit" or smthng like this

It is hard to know whether this refers to the BIOS of the host or maybe even the guest. But this might apply to your problem.

share|improve this answer
Execute bit? I am onit. – sinni800 Nov 17 '11 at 23:40
Damn, no. It still crashed. This is it, ASUS. Here comes your return... :/ – sinni800 Nov 18 '11 at 0:26
If you can return it, I suggest buying another model (although by the specs this is a very nice computer). – harrymc Nov 18 '11 at 6:42
Well here in Germany we have, by law, a 2 year "guarantee" that things must work. In those two years it's in the responsibility of the supplier to prove that I broke it. So if they can't prove that I broke it, they have to replace it. This means I'll only get another LE board. I'll check if I can find somebody with a similar setup, so we can switch processors. Then I will see if it's the processor or the board. – sinni800 Nov 18 '11 at 16:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .