Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Linksys WRT54GL router with gargoyle installed.

Unfortunately, I've forgotten my password so now I'm trying to reset it. I've already tried the 30/30/30 hard reset method, but it didn't work as expected.

After booting the router up the LED's power on in this order: the first one, then DMZ, and then the Wifi. After these three LED's are on, I can ping my router; the first reply has a latency of >1 ms and then the latency stays at =1ms.

I'm pinging it using the ping -t command on Windows via LAN card with the LAN LED light on.

When I Ctrl+C the ping process and then restart it, I get same result as before: first reply always >1ms and then = 1ms for all the rest.

I can't access gargoyle web interface, even though this router replies my ping. After waiting for at least 30 minutes, DMZ LED turns off by itself and I'm finally able to access the gargoyle web interface. Then I try hard reset 30/30/30 method but again, it resulted in nothing.

What I expect to be the solution is either a way to reset the password or to reflash firmware with another one.

share|improve this question
1  
30/30/30 should work , hope you are doing it the right way compnetworking.about.com/b/2009/03/11/… Or refer to the manual if it suggests another way to reset the device –  Shekhar Nov 9 '11 at 6:49
    
@shark I've tried this method but it didn't work as expected. The chronology I told above explain when I did 30/30/30 method. Btw, I appreciate for your answer. I'm glad to ask something in the right place. –  iroel Nov 9 '11 at 7:15

3 Answers 3

I got a reference from behappy on the Gargoyle Forum.

When you power up the WRT54GL N, the power LED starts blinking. You have to press the SES button many times so you can boot to the fail safe mode (Power and DMZ LEDs are blinking, web interface disabled).

telnet to it without password and execute

mtd -r erase rootfs_data 

Finally, the WRT54GL will reset.

share|improve this answer

For people who come across this in future: you can reset the password from failsafe mode without erasing data using the passwd command.

You may have to "mount_root" first if the passwd command gives you a read-only file system error.

share|improve this answer
  1. Open your Web browser and type the IP address of your router, enter your user ID And password when prompted

  2. At the top of the Web page, click “Administration” and then “Factory Defaults”

  3. Click the "Restore Factory Defaults" button and then click “Yes” when you are asked if you are sure if you want to reset your Linksys WRT54G.Now click the “Save Settings” button at the bottom of the Web page.

Source: http://linksys-wrt54g-firmware.blogspot.com/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.