Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It's weird, really weird.

  1. Windows 7 64 bit
  2. JEdit 4.4.1
  3. Autoarrange on desktop is disabled

Every time I open a .sql file that is on my desktop and I save it from JEdit, the icon of the file is put under the Bin Icon like when autoarrange is on. It just happens with JEdit.

share|improve this question

I guess your issue is caused by the two stage save feature (described below), disable it and see if it still happens.

Two-Stage Save

To prevent data loss in the unlikely case that jEdit should crash in the middle of saving a file, files are first saved to a temporary file named #filename#save#. If this operation is successful, the original file is replaced with the temporary file.

However, in some situations, this behavior is undesirable. For example, on Unix this creates a new i-node so while jEdit retains file permissions, the owner and group of the file are reset, and if it is a hard link the link is broken. The “two-stage save” feature can be disabled in the General pane of the Utilities>Global Options dialog box; see the section called “The General Pane”. http://www.jedit.org/users-guide/saving.html

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .