Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is it possible to make mplayer freeze in the last frame of the video instead of closing?

I am using CLI version of mplayer in linux.

share|improve this question
    
I have the same problem and use a bright xterm and the dwm window manager. My wife is always annoyed by the bright screen at the end of a longer movie. Starting a bounty. –  Sebastian Jan 7 '12 at 19:38
add comment

3 Answers 3

up vote 6 down vote accepted
+50

You can use this

#mplayer test.ogg -idle -fixed-vo
share|improve this answer
    
awesome, you are my hero. Note: This also works for the vdpau video output, although the manpage states only gl, gl2, mga, svga, x11, xmga, xv, xvidix and dfbmga –  Sebastian Jan 12 '12 at 14:41
    
here, it seems that, while the video does freeze at the last frame, the time controls (going back) do not work. Is it supposed to be like that ? Any way around it ? –  josinalvo Mar 2 at 23:07
add comment

You can do this with mplayer's slave mode. See:
http://www1.mplayerhq.hu/DOCS/tech/slave.txt

Also mentioned in the FAQ, 5th question under General Questions:
http://wiki.multimedia.cx/index.php?title=MPlayer_FAQ#General_Questions

Good luck!

share|improve this answer
    
Thanks for the quick reply. I also found the -slave and -idle options. The do prevent mplayer from exiting, however, they always close the video window. In my case, the bright xterm appears. Did I miss something? –  Sebastian Jan 7 '12 at 20:07
    
I don't have my Linux laptop handy so can't try at the moment, but I really believe its how I had it going in slavemode. A few guesses that I might have used is -fs for fullscreen, and maybe show_videowin set to yes in gui.conf? Hope some of those makes a difference. Another "ugly" workaround is to use the -loop option to just loop the movie a bunch of times, but that might be even more annoying. ;) –  Mattias Ahnberg Jan 7 '12 at 20:17
    
-fs does not work unfortunately. show_videowin does not apply to me, as I don't use the gui version. –  Sebastian Jan 8 '12 at 19:47
add comment

The feature you need can be supproted by adding new fscommands in a revised version. But the pause-on-last-frame feature will only work in wmp6.X rather than on 7.X.(Add the fscommand "fas.avclip.USEWMP6" to force utilize V6.X)

share|improve this answer
    
Can you clarify for me what you mean by "fscommands" and "revised version"? –  André Puel Nov 10 '11 at 0:57
    
I think wmp6 is related to actionscript/flash and not to mplayer. –  Sebastian Jan 7 '12 at 19:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.