Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is this a sign my repository is corrupted?

I ran svn up via ssh and quit in the middle (Ctrl+C) once I realised I made a mistake, then I tried again and it said to run svn cleanup so I did, ssh'ing into the machine. Then I tried svn up and waited and it never showed anything (still hasn't).

I then did svnadmin verify /root/of/repos and it successfully verified every revision (over 2400).

Then I suspected the copy was bad. So I checked out a new copy and replaced the old version. Checked out fine. However, that copy has the same symptom of basically running svn up in a way indistinguishable from a hang.

Anything else I can do or is my repository (and all changes) gone? :-(

share|improve this question
    
Made ssh verbose, it gets stuck at: debug1: Sending command: svnserve -t –  Tatsh Nov 10 '11 at 2:36
1  
Please answer your own question using the Answer your Question button, don't put "Solved: … " at the beginning. Thank you! –  slhck Nov 10 '11 at 7:09

2 Answers 2

Try to checkout the working copy on the server(by using the file:// URL), just to check that the repository is corrupt (I doubt that).

I think something is wrong whith you ssh tunnel

share|improve this answer

This had to do with my SSH tunnel. But also a technicality I have not seen mentioned in the SVN manual about the tunnel.

I could checkout with something like:

svn co svn+ssh://somesitehost.com/var/svn/repos

But I could not use svn up with that checked out copy. When I checked out, SSH automatically prepended my user name (which is the same as somesitehost.come) and used my SSH key for the handshake. This is normal behaviour.

Using svn up in this checked out copy left SSH stuck after authentication

debug1: Sending command: svnserve -t

I'm not sure what it was. The solution (I suppose) is to always use your full URI (with your name) to your tunnel. somesitehost.com won't cut it.

svn+ssh://tatsh@somesitehost.com/var/svn/repos/somerepo/trunk will always work.

I do find it strange that I can check out without a full URI but I cannot do anything else with the repository after that. Might as well be svn export.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.