Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

(Firefox 7.0.1 on Ubuntu 11.10 using Gnome Classic)

I had hoped my Firefox freezing issue would have been solved with the sqlite VACUUM method offered in this answer. It has helped, in that Firefox seems to freeze slightly less often.

Unfortunately, while slightly less, Firefox keeps freezing. It seems to happen if I leave it for a while without doing any tasks, but I am not 100% certain about that. In any case, at least once a day I have to force it to close:

enter image description here

I've run Firefox with the -g option to see if I get any debugging output, but it doesn't seem to report anything unusual. It looks like this around when I have to force a close:

[Thread 0xa97ffb70 (LWP 4301) exited]
[Thread 0xaddfeb70 (LWP 4287) exited]
[Thread 0xb01feb70 (LWP 4275) exited]
[Thread 0xb09ffb70 (LWP 4274) exited]
[Thread 0xb140ab70 (LWP 4272) exited]
[Thread 0xb24ffb70 (LWP 4270) exited]
[Thread 0xb2e9db70 (LWP 4266) exited]
[Thread 0xb369eb70 (LWP 4265) exited]
[Thread 0xb42ffb70 (LWP 4264) exited]
[Thread 0xac2fdb70 (LWP 4309) exited]

Program terminated with signal SIGKILL, Killed.
The program no longer exists.

I have tried removing all plugins, to no avail.

How can I get Firefox to stop freezing.

share|improve this question
Try uninstalling, then re-installing. – wizlog Nov 13 '11 at 18:54
If you create a completely new profile and switch to it, does the freezing stop? If so, when you switch back to your old profile, does the freezing happen again? – daxelrod Nov 14 '11 at 5:36
Sorry I wasn't clear with my suggestion. Firefox allows you to have multiple profiles and switch between them. I was suggesting you create a new one alongside your existing profile for testing purposes. – daxelrod Nov 15 '11 at 1:27
Before you do that, you can backup the profile with this command cp -r ~/.mozilla ~/.mozilla.bkup which will copy the .mozilla to .mozilla.bkup, or whatever you want to use. – Rob Nov 15 '11 at 20:18
@daxelrod: I started a clean profile, and slowly introduced my more critical plug-ins. So far so good. It doesn't identify what the problem was, but it might be the winning solution to just start fresh. If you post your suggestion as an answer, and assuming I don't get the freeze back, I'd award the bounty on that. – Questioner Nov 16 '11 at 2:11
up vote 2 down vote accepted

I would suggest using the Profile Manager to create a new profile alongside your existing one. The Profile Manager will let you choose which profile to use at startup.

In this new profile, disable all plugins. Use this new profile for a bit and see if the freezes keep happening. If they do, the problem is external to your profile; and has to do either with your Firefox installation or something else on your computer.

However, if the freezes don't happen in the new profile, you know it has something to do with the old one. You can start introducing plugins and extensions one at a time into the new profile to see if you can narrow down a culprit.

If the new profile is still running smoothly with all your plugins and extensions, try restoring data from your old profile, one piece at a time.

Through this process, you'll hopefully be able to deduce what's causing the problem, and if not, you'll have a new profile that doesn't cause the problem with most of your data in it.

share|improve this answer

I see that you have stated;

I have tried removing all plugins, to no avail.

Just to be certain, have you disabled Java? If so, a runaway script could also cause an issue such as this depending on how Firefox interprets said script. Also, some 'Ads' may also cause said crash.

I would suggest installing the following as a 'trial'; NoScript and AdBlockPlus. Both of these plugins are available directly through Firefox; Tools > Add-ons.

In case you have never used 'NoScript', when first installed and you visit a Webpage, no scripts will run. This means, for instance, login attempts will not work, website functionality based on scripts will not work, etc. When you visit a site, you can simply add the script to your approved list, very simply; Right-Click > NoScript > [Select Script]. Your "allowed" scripts will be remembered, you can also revoke rights.

I have had the exact same issue you have mentioned with Firefox on OS X and discovered it only occurred on certain webpages, using trial and error, banned scripts using NoScript and have not experienced the behavior since.

share|improve this answer
Out of curiosity, if plugins and scripts are disabled, how would an ad still cause a crash? – daxelrod Nov 18 '11 at 0:01
@daxelrod: Sorry, I do not do Web Development so I am not 100% aware of how Ads and scripts operate but, I have seen instances where YouTube, for instance, would run correctly even without allowing the script via NoScript; I believe it was a change on YouTube's side though. After seeing that, I was not sure if those same changes could be employed to deliver Ads, hence me mentioning AdBlockPlus as well, sort of like a safety net of sorts. – V_P Nov 18 '11 at 2:04
YouTube videos will play without JavaScript enabled because they use the Flash plugin. If you opt-in to their HTML5 trial, videos will play without even needing the Flash plugin enabled. – daxelrod Nov 18 '11 at 2:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .