Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a MSI Wind U100+ Netbook that is duel booted with Windows XP and Ubuntu Netbook Remix.

For version:

cat /etc/issue gives: Ubuntu karmic (development branch) \n \l

uname -r gives: 2.6.30-9-generic

Everything works great except the touchpad in Ubuntu does not want to perform the 'tap-click' action. The option is enabled in: Preferences -> Mouse -> Touchpad. The touchpad works in Windows XP and when I booted into an Ubuntu Live environment via USB. So I know the hardware actually works and that it is just a config issue.

Changing the window mode from netbook remix to ubuntu desktop changes nothing.

If possible aim answer towards a new Linux user please.

Thanks in advance.

share|improve this question
up vote 1 down vote accepted

Ok I solved my own problem =)

It can be fixed by enabling SHMConfig and then configuring the touchpad with the gsynaptics tool.

Enable SHMConfig:

$ gksudo gedit /etc/hal/fdi/policy/shmconfig.fdi

and put this in...

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="input.x11_driver" string="synaptics">
      <merge key="input.x11_options.SHMConfig" type="string">True</merge>
    </match>
  </device>
</deviceinfo>

Reboot your machine.

$ sudo apt-get install gsynaptics

$ sudo gsynaptics

and after changing the options located in gsynaptics it now works!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .