Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Force Chrome to open URLs as URLs, instead of searching

I'm surprised that I haven't found this question on superuser. Forgive me if it's a duplicate, but how do you disable the search functionality in Google Chrome's address bar?

I want it to be just a straight up address bar. I know the address where I want to go. I don't want to have to click the "did you mean to go to" link all the time when Chrome thinks the word I typed is more likely to be a search term than a server. You'd think putting the http:// in front would help, but I already do this by default anyway and no dice. =/

Thanks!

share|improve this question

marked as duplicate by JdeBP, Tom Wijsman, Sathya Nov 17 '11 at 4:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer

up vote 9 down vote accepted

You can't disable the search feature of the Omnibox.

You can disable instant search by clicking the wrench > options > basic and unchecking "enable instant."

A possible work around is to create a custom search engine for chrome. Right click in the Omnibox (search bar) and choose Edit search engines. You can create a blank search engine that will always fail by putting "no" "null" and "http://%s" in the Name, Keyword, and URL fields respectively.

If you're trying to point this to a local host, you could potentially use the URL field for this, though I have not tried this, and cannot confirm.

share|improve this answer
    
Okay. Is there a way to make Chrome aware of the servers I have set up in my hosts file? –  Suncho Nov 10 '11 at 6:37
1  
You'll have to elaborate on what you want to do. I've edited my answer to provide some more details and a possible work around. –  xdumaine Nov 10 '11 at 6:40
1  
Wow excellent. Works perfectly. Note that %s (without the http:// prefix) in the URL field works better for me because I might be visiting URLs using different protocols. –  Suncho Nov 10 '11 at 8:12
    
Nice, that worked just fine. I created a dummy custom search engine (Null   Null   null://%s) and set it as the default. Now typing a basic string does nothing. (It would have been easier, cleaner, and more versatile if they had not removed the ability to create engines without %s or containing JavaScript. ಠ_ಠ) –  Synetech Aug 21 '13 at 2:22
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.