Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to disable dpi scaling for Wireshark, except Windows won't let me:

enter image description here

Yet i pick any other random executable in the folder, uninstall.exe for instance, i can do it fine:

enter image description here

What gives?

i know Microsoft won't let you turn off scaling for their own signed applications:

enter image description here

But that's not the case here.

i also checked the wireshark.exe manifest, in the hopes of finding a clue there, only to discover that Wireshark isn't designed to run on Windows:

enter image description here

Why won't Windows let me disable high dpi scaling on wireshark.exe?

share|improve this question
+1 for thinking of checking the manifest. :) Have you tried running the "Compatibility Wizard" to see how it reacts? What edition of Vista is this? – Ƭᴇcʜιᴇ007 Nov 10 '11 at 14:43
i'm experiencing this on Windows 7, but presumably it applies to all versions of Windows that support dpi scaling, and the ability to turn it off (introduced with Windows Vista) – Ian Boyd Nov 10 '11 at 18:48
OK, what Edition of 7 is it then? Pro, Starter? 32-bit? 64-bit? It helps to formulate an answer when we have all applicable information. :) – Ƭᴇcʜιᴇ007 Nov 10 '11 at 18:51
Windows 7 Professional 64-bit. It begs the question, does the edition of Windows (Starter, Home Basic, Home Premium, Professional, Enterprise, Ultimate, N, KN, VL) affect the ability to set compatibility flags? – Ian Boyd Nov 10 '11 at 18:54
Probably not in this case, but knowing it's 64-bit from the get-go would have helped. ;) – Ƭᴇcʜιᴇ007 Nov 10 '11 at 18:56
up vote 3 down vote accepted

If the software you are using (Wireshark in this case) is 64-bit, then the compatibility boxes will be unavailable.

You can try setting the compatibility flags directly in the registry which are at the following registry location:

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

In that key, create a (string) entry as such:

  • Name: The full path to the application's .exe
  • Type: REG_SZ (String)
share|improve this answer
Incredible. i had no idea that 64-bit apps couldn't be shimmed through the UI. Adding the registry key manually solved the issue. Great job! – Ian Boyd Nov 10 '11 at 18:51
I think it's because they figure there's no reason to make a 64-bit application "compatible" as they won't be "legacy" in the first place (currently, anyway :) ). – Ƭᴇcʜιᴇ007 Nov 10 '11 at 18:53
The most recent Windows 8 update did something to Powerpoint on my Surface Pro to make it all blurry. Disabling DPI scaling was the solution, but because it's 64-bit, I couldn't do it through the GUI. this solution worked like a charm, except that the data value for me needed to be "~ HIGHDPIAWARE" instead of "HIGHDPIAWARE" – Mike Monteiro Oct 24 '13 at 15:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.