Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use a Mac Pro with two ethernet cards:

  • Ethernet 1 is connected to an Airport Extreme (NAT) in turn connected to my cable modem
  • Ethernet 2 is connected to an Airport Extreme (Off-Bridge Mode) which provide a WiFi to my devices
  • A VPN connection (tried PPTP and L2TP) is setup on the Mac Pro, routing shows it's going to Ethernet 1
  • On the Mac Pro, Internet Sharing allow connections from Ethernet 2 to use the VPN (PPTP or L2TP) connection
  • DHCP server on Ethernet 2 is provided by the "Internet Sharing" feature of OS X (10.7.2 btw)

From a computer connecting to the WiFi, I can browse site such as www.citrix.com but not www.google.com.

The traceroute looks like this:

traceroute www.google.com
traceroute: Warning: www.google.com has multiple addresses; using 74.125.224.146
traceroute to www.l.google.com (74.125.224.146), 64 hops max, 52 byte packets
 1  192.168.2.1 (192.168.2.1)  1.988 ms  1.487 ms  0.939 ms
 2  * (removed).reliablehosting.com (207.204.252.129)  209.598 ms  209.922 ms
 3  10g-207-gtwy.reliablehosting.com (207.204.224.1)  468.061 ms *  526.190 ms
 4  port-channel2.ar1.snv2.gblx.net (208.49.147.37)  306.996 ms  306.711 ms  309.272 ms
 5  74.125.49.85 (74.125.49.85)  211.863 ms  306.437 ms  307.208 ms
 6  209.85.249.3 (209.85.249.3)  279.174 ms  307.164 ms  306.882 ms
 7  64.233.174.119 (64.233.174.119)  307.335 ms  306.395 ms  307.177 ms
 8  nuq04s09-in-f18.1e100.net (74.125.224.146)  307.209 ms  412.244 ms  306.625 ms 

Ping works just fine too but yet I can seem to access a range of web sites, I initially thought that this could be due to some form of double NAT configuration but the trace route looks fine.

I am puzzled as I don't know what else to look for.

share|improve this question
    
Are you sure these websites are not being blocked by the VPN, based on the fact its reporting google has having multiple addresses, I would say its the fault of the VPN. – Ramhound Nov 10 '11 at 18:15

I would suspect MTU/MSS issues in this case. Try dropping the MTU on the WiFi connected clients.

share|improve this answer
    
I never came to understand why this happen, after changing my VPN provider the issue solved itself – Daniel Da Cunha May 3 '12 at 2:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .