Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Ubuntu and Windows 7 each on its own partition. When I switch on the computer, I do not get the option of switching to Ubuntu. Windows 7 starts automatically.

share|improve this question

4 Answers 4

up vote 2 down vote accepted

You need to restore the GRUB bootloader. The Ubuntu Community site has a comprehensive set of instructions on this: Recovering Ubuntu After Installing Windows

share|improve this answer

Here are some slightly more verbose instructions on how to repair grub. http://ubuntuforums.org/showthread.php?t=1035999

share|improve this answer

Grub http://www.gnu.org/software/grub/ is a dual boot loader that you can install on the system, this will then give you the option to dual boot each OS.

share|improve this answer

It looks like your GRUB bootloader is no longer set as the default bootloader... follow the steps below.

Boot with a live cd that has grub. Issue this: su grub (enter) root (hd0,?) (? being where your original grub is) setup (hd0) quite

Done!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.