Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

What is my OpenId URL

EG: Bitbucket wants me to signup using my OpenId URL. I want to use Google just like i use in SuperUser but there is no obvious link to Click on just a textbox for OpenId URL

share|improve this question
2  
Go through the comments in googlecode.blogspot.com/2008/10/… –  Rishi Sep 4 '09 at 12:17
add comment

2 Answers

up vote 7 down vote accepted

It seems the OpenID URL displayed by stackoverflow is either incorrect or Bitbucket handles it incorrectly. What you have to do is to take that URL and strip off the query string, i.e. the '?' and everything after it.

For me the resulting URL is www.google.com/accounts/o8/id (not sure if the o8 part is the same for everyone).

It then seems to work correctly

share|improve this answer
    
It's the same for me. –  alex Sep 4 '09 at 12:18
    
only "www.google.com/accounts/o8/id" is required? –  Rishi Sep 4 '09 at 12:19
    
Thanks a lot Michael –  Rishi Sep 4 '09 at 12:20
1  
yes o8 is the same for everyone –  Revolter Sep 4 '09 at 12:32
1  
There are shortcuts like bit.ly/gopenid and tinyurl.com/googop (and probably many others; make sure to use one that will not be redirected to some phissing site in the future). But all is still for if you feel really geeky, according to Google at googlecode.blogspot.com/2008/10/… (And if you own a Google blog, then you can use that URL for a less secure OpenID 1.1 as well.) –  Arjan Sep 4 '09 at 16:51
show 3 more comments

You can get it from your Superuser profile page. It's between "Seen" and "Website".

If I goto the BitBucket site (via your link) and enter my OpenID pasted from my profile it takes me to the myOpenID (my OpenID provider) sign in page. This is the same page I get for any site. If I enter my password I get access to the site.

Apparently this doesn't work with the Google OpenID as displayed in your profile

I'm not in a position to take a screen shot at the moment

share|improve this answer
    
Did you try it? –  Rishi Sep 4 '09 at 11:46
    
That is the first thing i tried, its not working for my google account –  Rishi Sep 4 '09 at 11:48
2  
@Rishi - There's something different about the way Google handles OpenID. It caused Jeff & Co problems with these sites. There's at least a couple of questions over on meta.stackoverflow.com about this. –  ChrisF Sep 4 '09 at 11:49
    
Wait, i tried it again, the url was getting clipped in SU page, hopefully it should work now –  Rishi Sep 4 '09 at 11:51
1  
I'm using myOpenID (www.myopenid.com) I switched when Jeff first mentioned problems with Google. I keep Google as a backup –  ChrisF Sep 4 '09 at 11:55
show 10 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.