Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So, I've just upgraded my PC's CPU and RAM from an AMD Phenom X4 9600 with 2×2GiB DDR2-800 to an AMD Phenom II X6 1055T (the 95 version, HDT55TWFK6DGR) with 2×4GiB DDR3-1333.

The system worked - I'm using it now - but everything is a bit "off", for example:

  • The keyboard missed key strokes, and occasionally duplicated them.
  • The mouse is jumpy and unresponsive.
  • The audio output to the speakers is distorted.
  • The Nvidia display driver intermittently crashed and recovered.

Windows 7 wasn't reporting any hardware issues in Device Manager, as far as I can see all voltages, temperatures,etc are correct, the CPU model is supported by my motherboard (ASRock N68C-S) and isn't of higher power than my old CPU (both 95W).

After some quick investigation I discovered everything became normal as soon I started taxing the system (by running a CPU intensive test app), so I suspected one of the Cool'n'Quiet or Turbo Core type technologies was the cause. Having spent an hour or so rebooting with various different options switched on and off I have isolated the problem - I have had to Disable the Enhanced Halt State (C1E) setting in the BIOS to allow my computer to operate correctly all the time.

Why is this setting causing me a problem now? (It didn't with the old CPU)
Should I be concerned that I have to leave C1E disabled?
Is there some way I "fix" Windows somehow so I can re-enable C1E?

share|improve this question
1  
Sounds like a BIOS bug. Have you tried upgrading the BIOS? –  Sathya Nov 12 '11 at 3:48
    
Try reseating the RAM and the CPU. Make sure pins are not bent. Make sure you applied the heatsink correctly on the CPU, and that your thermal paste/pad spread well. Like Sathya suggested, check your BIOS version. If you are still having issues, make sure the RAM timings are correct. Rarely, but sometimes, parts just aren't compatible; try replacing your upgraded components with the old ones to make sure the issue is localized to the new parts, and not some OS fluke. –  evan.bovie Nov 29 '11 at 5:34
    
Did you actually check to make sure the CPU wasn't overheating? –  David Schwartz Jan 3 '13 at 0:56
    
@David I have had serious problems with overheating before (years ago) - so it's something I'm pretty cautious about. It's currently rare for the processor to exceed 50ºC, even under the heavier loads I impose on it (such as a long game session or multiple VMs), so I don't think that's the problem. This has been left for in excess of a year now (with no problems), maybe I need to try enabling C1E again just to see if it's still a problem (although having done nothing about it I suspect it is). –  DMA57361 Jan 3 '13 at 8:44

1 Answer 1

This is a CPU terminology, if this is enabled it acts as a power saving mode.

As explained in wiki -

C1 (often known as Halt) is a state where the processor is not executing instructions, but can return to an executing state essentially instantaneously. All ACPI-conformant processors must support this power state. Some processors, such as the Pentium 4, also support an Enhanced C1 state (C1E or Enhanced Halt State) for lower power consumption.

This is why you did not find this behavior when you where running a CPU intensive test app. You can find more details in the following links.

CPU-C-States-Power-Saving-Modes - Hardware Secretes

Enhanced Halt State (C1E) Reduces Clock Speed

www.tomshardware.com/reviews/3,920-4.html - Tom's Hardware

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.