Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Notepad++, there's a way to assign your custom shortcuts by going to
Run -> Modify Shortcut/Delete Command...

This brings up the Shortcut Mapper

I set up my custom shortcuts on Computer 1 I then installed Notepad++ with the same install settings and plugins on
Computer 2

I then created a zip archive of my Notepad++ folder in Program Files on Computer 1
I overwrote the Notepad++ folder in Program Files on Computer 2 with this archive

My custom shortcuts did not come across.
I thought that the shortcuts were saved in
C:\Program Files\Notepad++\shortcuts.xml

I compared
C:\Program Files\Notepad++\shortcuts.xml
from Computer 1 with the same file on Computer 2 and the
two files are identical.

Why then are the shortcuts not coming across to Computer 2?

Computer 1 is Windows XP
Computer 2 is Windows Server 2008 R2

share|improve this question
up vote 1 down vote accepted

You are correct in that it stores those shortcut maps in shortcuts.xml, but it's not saved to the one in the Notepad++ folder (at least not by default on Windows).

It's instead saved to your user's AppData folder:

  • On Windows Vista+ check C:\Users\<your user name>\AppData\Roaming\Notepad++
  • On Windows XP check C:\Documents and Settings\<your user name>\Application Data\Notepad++

Also, it appears that changes are not saved to that file until you close Notepad++.

share|improve this answer
    
Thanks, I need to build a script to put everything in the right place. Funny thing is when I installed Notepad++ on Windows Server 2008 R2 I checked the "Do not use %APPDATA%" option. I guess this option is useless on later Win versions. – Dean Toader Nov 11 '11 at 20:04

I found that Computer 2 (Windows Server 2008 R2) has a path

C:\Users\<user.domain>\AppData\Roaming\Notepad++  

where it gets all the settings that Computer 1 (Windows XP) was getting from

C:\Program Files\Notepad++  

Turns out I needed to copy and replace the following files from

C:\Program Files (x86)\Notepad++  

to

C:\Users\<user.domain>\AppData\Roaming\Notepad++>tree /F /A 
|   config.xml
|   contextMenu.xml
|   langs.xml
|   session.xml
|   shortcuts.xml
|   stylers.xml
|
\---plugins
    \---Config
        |   Compare.ini
        |   converter.ini
        |   Fileswitcher.ini
        |   npes_saved.txt
        |   NppExec.ini
        |   NppExternalLexers.xml
        |   NppExternalLexers.xml.backup
        |   NppExternalLexers.xml.backup2
        |   NppExtLexer_PluginHelp.txt
        |   NppPlugin_ChangeMarker.xml
        |   NppPlugin_PluginMargin.xml
        |   NppPlugin_SciMarkerSymbol.xml
        |   NppTextFX.ini
        |   PluginManager.ini
        |   PluginManagerPlugins.xml
        |   PythonScriptStartup.cnf
        |   RegRexPlace.ini
        |   SpellChecker.ini
        |   WndMgr.ini
        |
        +---NppFTP
        |       Certificates.xml
        |       NppFTP.xml
        |
        \---PythonScript
            \---scripts
share|improve this answer
  1. CLOSE all working notepad++ windows.
  2. There are two shortcuts.xml files. Synchronize at these locations:
    • C:\Users\<>\AppData\Roaming\Notepad++ (or C:\Documents and Settings\SoftVnn Member\Application Data\Notepad++)
    • C:\Program Files (x86)\Notepad++ (or C:\Program Files\Notepad++)

Then you've successful migrated the shorcut keys.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .