Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have to back up a 50 gig file to an external drive weekly. If I plug it into USB, the server hangs (nonresponsive explorer etc). Tried 2 different drives with same result.

Googling suggests this is due to the drive getting assigned a drive letter that's already taken. If that's correct, how can I work around it? Right now I'm transferring the file over the network... takes forever. I tried booting with the drive plugged (works ok) and assigning it a high drive letter, but if I unplug and replug it, it hangs again. I want to be able to do this every week without rebooting the server.

share|improve this question
Have you tried other USB drives in the 2003 machine? How about trying the drive on a different machine? This will help narrow down if it's the drive or the computer with the problem. –  Ƭᴇcʜιᴇ007 Nov 11 '11 at 20:16
howdy... I did try 2 different drives with the same result, and both drives plug into a modern windows 7 PC with no issue. I think it's the operating system, I've seen other people with similar issues say it's windows getting hung up assigning the drive letter to the new drive. What I haven't seen is a working fix for this. –  CreeDorofl Nov 17 '11 at 21:07
I am seeing the same with a thumb drive. I have MSE disabled (it was enabled). I see an EventID 51 "Erorr detected on device \Device\Harddisk1" when it happens. In theory - this is an existing drive with an assigned letter. The thumb drive sometimes works with the server, but once in this state - stays in it for a while. –  Danny Staple Nov 11 '13 at 10:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.