Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed a package with Yum (Varnish 3.0.2). However, a feature I need has been removed so I need to roll back.

According to the documentation, the feature was removed in 3.0-Beta, so I wanted to revert to the latest version prior to that. (This is 2.1.5)

This is installed now, but there were three RPMs to install for it (from

After some faffing about with missing dependencies these got installed. However, the feature I need is still not there. I'm wondering if one of the dependencies is actually from a newer build.

Do you know how I can see the versions of all the dependencies of a Yum installed package?

share|improve this question

migrated from Nov 12 '11 at 7:04

This question came from our site for professional and enthusiast programmers.

yum deplist <your-pacakge-name> does not work? – hovanessyan Nov 11 '11 at 18:25
@hovanessyan Thanks, this doesn't show the version numbers though, only filenames. – BanksySan Nov 14 '11 at 10:26

@hovanessian is right. You won't get any more than what deplist shows.

There are few kinds of dependencies in spec file:

  • file dependencies

    dependency: /usr/bin/env provider: coreutils.x86_64 8.4-16.el6

    There is no version as the file may be provided by multiple packages

  • virtual dependencies

    dependency: python(abi) = 2.6 provider: python.x86_64 2.6.6-29.el6

    The package "provides" some features, other packages can depend on. For example python package provides versioned python(abi).

  • package dependencies

    dependency: python-twisted-core >= 8.2.0 provider: python-twisted-core.x86_64 8.2.0-4.el6 provider: python-twisted-core.i686 8.2.0-4.el6

Virtual and package dependencies may be versioned and if there is no exact version listed you may try earlier/later version but results are not always satisfactory.

More on dependencies:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.