Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I heard you can use facebook chat on desktops now. Thats awsome! What i didn't hear is that it is a pain in the butt! Not awsome!

I've followed six nearly identical sets of instructions from six different websides, including the one that facebook generates for you, to get facebook chat connected through Pidgin. Its the latest portable version, so from what i hear the plugin is out of the question.

Whenever I go to try and connect i get a message saying "Not Authorized" and buttons to either modify the account info, or retry.

NOTHING i have done has fixed this, and I can't find anything remotely usefull anywhere.

I am running windows xp, and running pidgin (portable) off of a flash drive. Someone please tell me what i have to do.

I read about authorizing the chat on my actual facebook page. I'd have tried that if i could find out how to do it, but if its there they hid it good. HELP?!

share|improve this question

4 Answers 4

I had the same issue with multiple XMPP clients. After trying every fix suggested on the web, I still had no luck. Finally, looking through settings to see if there was a Facebook Chat specific setting I needed to modify, I realized that I had turned the App Platform off some time back. On a whim, I re-enabled it, and finally I can connect from XMPP clients. Connecting externally from an IM client is considered a Facebook App, and so therefore the App Platform is required.

To turn it back on, go to your Applications tab under Security and click the button:

enter image description here

share|improve this answer
1  
+1, this was way too frustrating to figure out. They should at least have some warning message. –  Blender Dec 12 '13 at 4:35

I have had the same problem. Using the hint with logging in with the username using the browser did not help.

Here is the solution that helped me (using Pidgin 2.10.4):

  • Select "Accounts", then "Manage Accounts".
  • Select the account that you intent to use for Facebook and select "Modify...".
  • Now select the tab "Advanced".
  • In the field "Connect server" enter the data from the basic tab's field "Domain" – in my case: chat.facebook.com
  • Now you just need to select "Save" and tick your account to activate it.
share|improve this answer

It seems to work for me with no additional work with the following settings

On mine, the settings are

under the basic tab:

username : facebook username as per the part after https://www.facebook.com/ when you view your own profile

domain: chat.facebook.com

password : same password as facebook

Under the advanced tab: connection security: "Use encryption if available" port: 5222

share|improve this answer

There is a problem with Facebook that happens if you log in using your email account instead of your Facebook username.

If you log in using your email, log out, log in using this time your Facebook username and then try to connect again to Facebook chat through Pidgin.

share|improve this answer
1  
Not working for me that solution. I've logged in and out and I still get "not authorized" error. –  Rafaesp May 17 '12 at 22:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.