Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The auto play on my DVD drives suddenly stopped working for some reason. Even with store-bought DVDs it does not work, although I can watch movies quite successfully if I run Windows Media Player and then manually select the drive.

I have tried setting the autoplay options through Start » Set Default Programs and setting Default programs. I cannot get autoplay to work.

My theory is that it is not recognizing when a new DVD is ready and that autoplay is never called. When I insert a new DVD, it's ready for a little while but then the access light goes out. When I use the computer, the DVD name shows up, but when I try to play the DVD I get told that there is no program associated with the DVD and that I should set as one to the Start » Set Default Programs, as mentioned above.

If I reset to the "ask me each time" and try reinserting the DVD, it never asks me what to do. It merely reads the desk for a little while and then stops – exactly as above.

Any ideas? (Oh! Win7)

share|improve this question
which Windows version? – Nate Koppenhaver Nov 12 '11 at 20:03

so I finally figured out what was wrong: apparently I was missing a registry value. What I determined :

Open regedit and locate the following key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Change: NoDriveTypeAutorun to 0x91

If necessary create this key as a DWORD.

I found this in:

Change/add this value, and then reboot. Voilà! – Autoplay is back!


share|improve this answer
Actually, the reboot is not needed – greenber Nov 14 '11 at 2:08
Sir, if you found the solution please mark it as solve as it helps for other users too. – avirk Jun 20 '12 at 3:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .