Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After I upgraded to Windows 7, the Memory Stick PRO Duo driver does not work; the card simply is not detected at all. I searched for the driver but could not find any. Does anyone has a solution to this? My particular model is Sony VGN-NS140E.

share|improve this question
    
So, when you connect the card, literally nothing happens? Does the driver wizard pop up? (You should only be looking for a driver if you actually see a device that has no driver. Did a driverless-device show up?) Does nothing show up in the Disk Manager? –  David Schwartz Nov 13 '11 at 0:53
    
Sorry for late reply. In device manager, it does says =Other Devices - Base System Device (with yellow sign on it). Note that this memory card reader is inside the laptop itself. And a lot of ppl are having problem with it in win7. –  Dave Nov 14 '11 at 12:41

2 Answers 2

up vote 1 down vote accepted

I spent days on finding the driver but could not. Here it is how to find your sony driver for memory card pro on Windows 7.

  • Go to sony support site
  • Enter your model number, it is usually written below the laptop screen on right
  • If your model is found, it will display a result. Click the second tab from left "Drivers and Software"
  • Select Windows 7 (or Windows 7 64bit) depending on what you have. In the second combo box, select "Memory Stick".
  • Your driver should be in front of you.

Download the driver and install it. Then restart the PC (it will not say it but it is required) and your memory stick pro car will be working in Windows 7.

Note that in my case I searched for VGN-NS140E model, 64bit Windows 7 and the driver worked.

share|improve this answer

I was searching for days for it...I have a dell but I guess it also works for other computers . Ricoh has a multi driver to solve this problem, it worked for me. See link below and that driver might works for You too : )

http://www.dell.com/support/drivers/us/en/19/DriverDetails?driverId=38DVK

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.