Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

Sometimes when I'm playing games which are heavy on the GPU, Windows decides to helpfully disable aero, causing everything to freeze for a bit and in the worst case, combined with ATI's brilliant drivers, causes the game to crash.

So,

How do I stop Windows from automatically disabling Aero when playing games? It has absolutely no effect on the performance of the game itself when it does that.

Also, I'd like to get rid of the "You should disable Aero to improve performance" helpful hint popup which sometimes shows up. But I suppose getting rid of the first will get rid of the second, assuming anyone knows how.

share|improve this question

marked as duplicate by Ƭᴇcʜιᴇ007, Kevin Panko, Tog, Gnoupi, Heptite Mar 7 at 0:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I wish there was an answer to this, windows 7 occasionally just decides that aero is too much for my ridiculously beefy system to handle, and switches me out without asking. it's fairly bullshit. I'd love to know how to disable that 'feature,' because it's obviously not functioning as intended in this case. –  matt lohkamp Mar 22 '12 at 7:11
    
Sounds exactly like my case. Seems there just is no solution to it. I suspect bad drivers cause some of it. –  Jani Hartikainen Mar 22 '12 at 16:32
    
could be. it started pretty soon after slotting in a new video card. but I haven't even noticed it happening during anything that seems like it should be gpu-intensive - it's usually while I'm just browsing or something. I was kind of wondering if it had to do with my display setup - I've got two running off the primary card, plus another off the onboard setup as a secondary card. –  matt lohkamp Mar 22 '12 at 22:25
    
Go the other way, try using something like Razer Game Booster to disable/re-enable Aero automatically when playing games. –  Tog Mar 6 at 8:06

3 Answers 3

The only times I've come across this is if the game is in Compatibility Mode with the "Disable themes" option set. Are you playing in compatibility mode?

share|improve this answer
    
Nope, most recently encountering this issue with Battlefield 3. Had it happen with other games too. –  Jani Hartikainen Nov 13 '11 at 5:41

While this does not directly answer your question, you could solve your problem by disabling Aero while playing the game.

If you have a shortcut to your game, go

[right click] -> Compatibility -> Disable desktop composition -> OK

share|improve this answer
1  
I would prefer to keep Aero enabled (I alt tab out occasionally etc.). Thanks for pointing out this option though, if it comes to this, it is probably better than nothing. –  Jani Hartikainen Nov 13 '11 at 5:43

There are in my experience three reasons Aero gets disabled:

  1. The application has enabled the compatibility setting to disable Aero.
  2. Something is incompatible with Aero, like the overlay video renderer in Vista, or low color quality.
  3. The application requests that Aero is to be disabled.

Case 3 is the the usual case for games. In that case it is not a Windows setting you need to change but a game setting. And those settings aren't usually exposed in the Options dialogue. You'll have to edit ini files. The specifics depend on the game in question.

Case 2 can also rear its head with games. Usually due to some weird graphics setting or graphic driver problem.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.