Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It is very annoying. When browsing a website that I know is not in English and I trust Googles translation the popup some times comes and destroys the layout and it's impossible to work with the website then. If only the pop is disabled (more like , yeah please no popups for the next hour or so, but I guess that would ba feature)

share|improve this question

4 Answers 4

In Google Chrome options, there is an option to disable this. Click on the wrench icon and then on the "Under the hood" tab and look for "Suggest to automatically translate sites..."

share|improve this answer
    
that stops translation altogether. I want translation but not the popup –  Shahzada Hatim Nov 14 '11 at 8:16
    
I don't think that's an option you can change then. You could try the Google Code forums for Chrome and ask there. –  rdrgrtz Nov 14 '11 at 19:19

After you choose to translate a page, click "Options" on the right side of the bar. Choose "Always translate X to Y," and I think that will kill the popup.

share|improve this answer
    
if it worked like this then there would not be any issue. –  Shahzada Hatim Aug 8 '12 at 9:17

I just had to go into Google settings Click on Advanced settings at bottom of page. Click on Rest Browser Settings and it cleared the annoying pop up !!

share|improve this answer

If you disable Translation on Chrome settings you can still translate sites on different languages than yours by right clicking on any page and choosing "Translate to ......"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.