Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just set up a DNS Server on my Windows 7, called SimpleDNS.

I added a zone for example sag.com and defined www.sag.com and sag.com to 192.168.1.2 (my Network IP Address) . the problem is when I try to ping sag.com the SimpleDNS logs says that it answered the request with 192.168.1.2, but the ping doesn't resolve anything . SimpleDNS logs:

 14:00:43   Request from 192.168.1.2 for A-record for www.sag.com
 14:00:43   Sending reply to 192.168.1.2 about A-record for
 www.sag.com: 14:00:43   -> Answer: A-record for www.sag.com =
 192.168.1.2 14:00:43   -> Authority: NS-record for www.sag.com = mehr-pc

nslookup yields:

 C:\Users\Mehr\Desktop>nslookup www.sag.com DNS request timed out.
     timeout was 2 seconds. Server:  UnKnown Address:  192.168.1.1

 DNS request timed out.
     timeout was 2 seconds. DNS request timed out.
     timeout was 2 seconds. DNS request timed out.
     timeout was 2 seconds. DNS request timed out.
     timeout was 2 seconds.
 *** Request to UnKnown timed-out

The DNS server IP is 192.168.1.2 , and Access point address : 192.168.1.1

What should I do?

share|improve this question

migrated from serverfault.com Nov 12 '11 at 23:35

This question came from our site for professional system and network administrators.

3 Answers 3

run:

nslookup sag.com (ip of dns server)

the above command will forcefully try to resolve name from your dns. then analyze the result that what it says to you.

Verify that the DNS server is running and LISTENING on required ports. verify that port 53 (UDP) is open.

The difference between ping and nslookup is that when ping is submitted to OS, the OS tried to resolve name from all possible way (through lmhosts, hosts, dns, and total of 7 ways), but nslookup only resolves name from provided dns server.

share|improve this answer
    
it listening on port 53 , it logs show that it answers the requests. I'm gonna run the command and copy here the results and logs , thank you for your reply –  Behrooz A Nov 12 '11 at 10:26
    
I just edited my post –  Behrooz A Nov 12 '11 at 10:37
    
what is IP of your DNS server? and what is the DNS server set on your local system? and i told you to run command e,g,"nslookup sag.com 4.2.2.6",,you have to replace 4.2.2.6 with your dns server ip address. –  Farhan Nov 12 '11 at 10:39
    
C:\Users\Mehr\Desktop>nslookup www.sag.com 192.168.1.2 Server: UnKnown Address: 192.168.1.2 Name: www.sag.com Address: 192.168.1.2 –  Behrooz A Nov 12 '11 at 10:51
    
your DNS server ip is 192.168.1.2 ? –  Farhan Nov 12 '11 at 10:53

Setting up a DNS server is one thing using it another one.

It may sound trivial, but it is necessary to explicitly enter it to be used.

So the first step to do is Frank's approach, and if that works, but the same command without the IP of the DNS server doesn't, it means that your DNS server isn't used per default.

share|improve this answer
    
Dear glglgl , according to your post and nslookup , it looks that my DNS server doesn't act as primary or default one , is it a problem in my access point where I changed primary DNS server ( and leaved secondary as blank) ? –  Behrooz A Nov 12 '11 at 11:07
    
Seems so. Normally your access point should distribute its DNS settings via DHCP. Why it doesn't? N idea. But maybe it helps to set the NS data at the clients - depending on their number. At least, it is worth a try. –  glglgl Nov 12 '11 at 18:31
    
It's for a shop, customers can't get forced and don't have enough knowledge to do it. also , the weird thing is on each try DNS responses to request ( as shown in dns logs ) but nothing to show in nslookup and ping or in browser –  Behrooz A Nov 12 '11 at 18:35

Your nslookup shows your Windows 7 computer is using 192.168.1.1 as it's DNS server, not 192.168.1.2. You need to change the DNS server in the TCP/IP properties of the NIC.

share|improve this answer
    
it should should DNS server address in DHCP , from 192.168.1.1 ( the access point ) , I set the DNS in access point , so I think it's okay that the address of DNS server be 192.168.1.1 my current DNS server which works perfect , is set via ISP DHCP in access point and in my computer set to 192.168.1.1 and in TCP/IP of the NIC , it uses DHCP too , not manual IP assigning. you mean every node that joins the network must set their DNS manually ? I don't think so this is the right answer because it uses DHCP from an access point which the DNS server is set in it. –  Behrooz A Nov 12 '11 at 13:18
    
If you've configured 192.168.1.1 to use 192.168.1.2 as it's forwarder then that's OK, but it's not working as evidenced by your nslookup. The nslookup is timing out. Try running nslookup for www.google.com and see if that works. Then try changing your Windows 7 computer to use 192.168.1.2 as it's DNS server and run nslookup for www.sag.com and www.google.com and see if that works. The results of these tests should help you narrow down the problem. –  joeqwerty Nov 12 '11 at 13:31
    
C:\Users\Mehr\Desktop>nslookup google.com Server: UnKnown Address: 192.168.1.1 Non-authoritative answer: Name: google.com Addresses: 209.85.148.106 209.85.148.147 209.85.148.99 209.85.148.103 209.85.148.104 209.85.148.105 –  Behrooz A Nov 12 '11 at 13:33
    
It works with google. I tried it with my Android phone too. nslookup-ed and the same answers in computer –  Behrooz A Nov 12 '11 at 13:34
    
So 192.168.1.1 is working for external names but not internal names. Is 192.168.1.1 configured to use 192.168.1.2 as it's DNS forwarder? The DNS queries for sag.com have to get to 192.168.1.2 or it's not going to work. –  joeqwerty Nov 12 '11 at 13:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.